summaryrefslogtreecommitdiff
path: root/net-news/alligator/alligator-23.08.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-news/alligator/alligator-23.08.1.ebuild')
-rw-r--r--net-news/alligator/alligator-23.08.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-news/alligator/alligator-23.08.1.ebuild b/net-news/alligator/alligator-23.08.1.ebuild
new file mode 100644
index 000000000000..6a0205f05e42
--- /dev/null
+++ b/net-news/alligator/alligator-23.08.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="forceoptional"
+KFMIN=5.106.0
+QTMIN=5.15.9
+inherit ecm gear.kde.org
+
+DESCRIPTION="Convergent RSS/Atom feed reader for Plasma"
+HOMEPAGE="https://apps.kde.org/alligator/"
+
+LICENSE="|| ( GPL-2 GPL-3 ) CC0-1.0 CC-BY-SA-4.0 GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+DEPEND="
+ >=dev-libs/kirigami-addons-0.6:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=dev-qt/qtsql-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-frameworks/syndication-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"