summaryrefslogtreecommitdiff
path: root/net-nds/rpcbind/rpcbind-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-nds/rpcbind/rpcbind-9999.ebuild')
-rw-r--r--net-nds/rpcbind/rpcbind-9999.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/net-nds/rpcbind/rpcbind-9999.ebuild b/net-nds/rpcbind/rpcbind-9999.ebuild
index aada63a85850..51778b3ddf63 100644
--- a/net-nds/rpcbind/rpcbind-9999.ebuild
+++ b/net-nds/rpcbind/rpcbind-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit systemd
@@ -10,7 +10,7 @@ if [[ ${PV} == "9999" ]] ; then
inherit autotools git-r3
else
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi
DESCRIPTION="portmap replacement which supports RPC over various protocols"
@@ -21,13 +21,13 @@ SLOT="0"
IUSE="debug remotecalls selinux systemd tcpd warmstarts"
REQUIRED_USE="systemd? ( warmstarts )"
-CDEPEND=">=net-libs/libtirpc-0.2.3:=
+DEPEND=">=net-libs/libtirpc-0.2.3:=
systemd? ( sys-apps/systemd:= )
tcpd? ( sys-apps/tcp-wrappers )"
-DEPEND="${CDEPEND}
- virtual/pkgconfig"
-RDEPEND="${CDEPEND}
+RDEPEND="${DEPEND}
selinux? ( sec-policy/selinux-rpcbind )"
+BDEPEND="
+ virtual/pkgconfig"
src_prepare() {
default