summaryrefslogtreecommitdiff
path: root/net-misc
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/Manifest.gzbin55071 -> 55071 bytes
-rw-r--r--net-misc/wol/Manifest2
-rw-r--r--net-misc/wol/files/wol-0.7.1-musl.patch45
3 files changed, 46 insertions, 1 deletions
diff --git a/net-misc/Manifest.gz b/net-misc/Manifest.gz
index 0809e32253a4..0b45e5f55246 100644
--- a/net-misc/Manifest.gz
+++ b/net-misc/Manifest.gz
Binary files differ
diff --git a/net-misc/wol/Manifest b/net-misc/wol/Manifest
index 7cd83724e2bd..1de80c37aacc 100644
--- a/net-misc/wol/Manifest
+++ b/net-misc/wol/Manifest
@@ -1,4 +1,4 @@
-AUX wol-0.7.1-musl.patch 347 BLAKE2B 4ebedc009fb77556004f8bdda8679ca2f0eaca22145aa395a69ce6e78319a6c3fb430bc4ea30c4887dd4e870ad1ff36d7369ec3dc50a419bc5e8ebcdd29ebd7e SHA512 b7568aa53f20a0402aeb9ed579fab2846245df134c000cc4483ce63f01ec64943708595fff9f78c73e6c6156ddd06781314dee46a06c216c9abcd0f1ec696208
+AUX wol-0.7.1-musl.patch 1123 BLAKE2B ff9efe257a32f3ce484ee978bee7d8b8d706d28934f83c00e7c5edaab1e04186b8d31db6a2e90bab9be7406c9caeb298fcef377d3f59a31c77b7fe9276a0f8de SHA512 670a860f02d82dd9fae8216d47629fc81f9acfa6bfdd9e38125b0e84604d14998539cb7d9c0cce15e49a52e8b38336c6475d3a5b0ec0763746b1bccd4f2f64cb
DIST wol-0.7.1.tar.gz 445648 BLAKE2B 80e34ee5a588f7caec92c17d3455abec8227789c30dcde46ecbb75d2f5d7f2a852f6a8c11dea54c036e63db73e28f6d2aaa32bbf7b5708f23c9005f163a17f5f SHA512 233cbd038633c4b04a22710c04a8349d7706c6b4ff0554b6899ee3309349502a318f6fb05a4ad4c80cd373c362b2ad8818cb52a432d768f569e80f05658615a3
EBUILD wol-0.7.1-r3.ebuild 605 BLAKE2B a745251d60a5b7b932aa74f379e16101197c3e4891161ca77f83256dd646a4c107b800262b8f8f6faa70a435fc7541ee9146b0b99a7420bcbe08c5a347a50e6e SHA512 7dce445920605d46ad2f97cb69a9022cd7a5a686c665bb4d8c2bf038b6d58b77796243b349cd6de03258d2c63ca1c1eee69334a13774aa3805177dd893747fd5
MISC metadata.xml 617 BLAKE2B bafbe2d18eaafd5934c3d5f341076bd442700e774068cf8f143310a16b689d3140ee72fa600fc7bdcb638c5972199c96cf5534a8612565ab02192bf06507d422 SHA512 e402abeecb6242c052247d9385e3ebfd8fd8c6cf4f70b95bf244edcd32cd9b2efd0a24be8ece1353f56d51e81acc902148c68043d1ab100cc78a471c6b663dfd
diff --git a/net-misc/wol/files/wol-0.7.1-musl.patch b/net-misc/wol/files/wol-0.7.1-musl.patch
index c7c0dc6028ca..3b9098554370 100644
--- a/net-misc/wol/files/wol-0.7.1-musl.patch
+++ b/net-misc/wol/files/wol-0.7.1-musl.patch
@@ -15,3 +15,48 @@
+# endif
#endif /* not GETLINE_H_ */
+--- a/lib/realloc.c
++++ b/lib/realloc.c
+@@ -20,21 +20,15 @@
+ #if HAVE_CONFIG_H
+ # include <config.h>
+ #endif
+-#undef realloc
+
+-#include <sys/types.h>
+-
+-char *malloc ();
+-char *realloc ();
++#include <stdlib.h>
+
+ /* Change the size of an allocated block of memory P to N bytes,
+ with error checking. If N is zero, change it to 1. If P is NULL,
+ use malloc. */
+
+ char *
+-rpl_realloc (p, n)
+- char *p;
+- size_t n;
++rpl_realloc (char *p, size_t n)
+ {
+ if (n == 0)
+ n = 1;
+--- a/lib/xmalloc.c
++++ b/lib/xmalloc.c
+@@ -20,15 +20,7 @@
+ #endif
+
+ #include <sys/types.h>
+-
+-#if STDC_HEADERS
+-# include <stdlib.h>
+-#else
+-void *calloc ();
+-void *malloc ();
+-void *realloc ();
+-void free ();
+-#endif
++#include <stdlib.h>
+
+ #if ENABLE_NLS
+ # include <libintl.h>