summaryrefslogtreecommitdiff
path: root/net-misc/zssh/zssh-1.5c-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/zssh/zssh-1.5c-r2.ebuild')
-rw-r--r--net-misc/zssh/zssh-1.5c-r2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-misc/zssh/zssh-1.5c-r2.ebuild b/net-misc/zssh/zssh-1.5c-r2.ebuild
new file mode 100644
index 000000000000..e63204a2c9bb
--- /dev/null
+++ b/net-misc/zssh/zssh-1.5c-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="SSH wrapper enabling zmodem up/download in ssh"
+HOMEPAGE="https://zssh.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc sparc x86"
+IUSE="nls readline"
+
+DEPEND="readline? (
+ sys-libs/ncurses:0
+ sys-libs/readline:0
+ )"
+RDEPEND="${DEPEND}
+ net-dialup/lrzsz
+ virtual/openssh"
+
+src_prepare() {
+ eapply "${FILESDIR}/${PN}-1.5a-gentoo-include.diff"
+
+ # Fix linking with sys-libs/ncurses[tinfo], bug #527036
+ sed -i -e 's/-ltermcap/-ltinfo/g' configure || die
+
+ eapply_user
+}
+
+src_configure() {
+ tc-export AR CC RANLIB
+ econf \
+ $(use_enable nls) \
+ $(use_enable readline)
+}
+
+src_install() {
+ dobin ${PN} ztelnet
+ doman ${PN}.1 ztelnet.1
+ dodoc CHANGES FAQ README TODO
+}