summaryrefslogtreecommitdiff
path: root/net-misc/youtube-dl
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest2
-rw-r--r--net-misc/youtube-dl/youtube-dl-2020.01.24.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 868722cc2870..0017a43004c1 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,4 +1,6 @@
DIST youtube-dl-2020.01.15.tar.gz 3159264 BLAKE2B 4f7b527e02e5ce6923f66db322c4ba8695e6e2850b7bcf4353914a27c31c7d5d28980b948326585bd2a25b76f4d7e903e8589fe1f137d905aca9ad30d54818d2 SHA512 1b450feef1d6040726f99e482edb6119b66224a98bdec1983f6921f21b08bd8fceb77cff055326b660fb66742815e5e0238807707547ef82b51b9966fdc82be7
+DIST youtube-dl-2020.01.24.tar.gz 3159926 BLAKE2B 0b1be74f74eb0be6cb0a41faf0538110bfc5d1a213fa1c456a6a358096f16ac8768ebd3d4673e523251fd0721a4a0990f061713d32b13c11077e79f8f02989e1 SHA512 8f85a218395d2932b26c7b76d5b03cbdf9a7c541415c8d1b805239b6ab1ca74b94fc497f32052a1d93fe20ac760994975a13551dd8c5319f0549af20b70a1a78
EBUILD youtube-dl-2020.01.15.ebuild 2239 BLAKE2B b0b08d37700f463c53c955d4396dd98eeaaaccd7573b8db735dd7ca52451fa41b0f24344d73b00e78fbb2a86e068373db8bfead32b1ebfca9a38408315a0bc1d SHA512 c82a5b508a3941afaa771dffbd88ca3fdff8fd1af5e1b13a0087790f76911c7cd98ad2f5d45ea1eb257d796ec302d59120197241e9685e9897f590b8af308886
+EBUILD youtube-dl-2020.01.24.ebuild 2245 BLAKE2B c555a3f395758ae90ad46f0db73dd28c9e98d38dfec4de8929edbc0f0f566847725c6ea4c3bec32bc2cb8ee4cda9e0c10c451d19f1cdcf6cf77e57577519b5dd SHA512 57e369eab168d96c31721ab6eb59021b73ef55e5571f5d4029fd9250907061a38f1aaacc0ccce528d0bfa33365f5b53c76400bdde116d8b50733915591de55f2
EBUILD youtube-dl-99999999.ebuild 2142 BLAKE2B 1f9fdb555f7f4fb60cfde00f72e037149e9d12458984127dd72c5fb75c27fb6cb4590dc3b81986d8f42d0beee66aed95f5efd5527de21e2b1be6d0065dd5664a SHA512 572c11fd1428ab7ee83a3e6deadf68c378b3ff4f47dca74dcf8604fb4e82e1d8e6f55e64cb1067d011143f212dfff27f923c739834e46f0b226683bfa2c31f87
MISC metadata.xml 218 BLAKE2B 717fcfd86a1f75e0ad21845c9b496cf01d7bc7c80b6be8c08143ea304a08fbb75352e82e8fc883398e96da9c037f8912c4a9612b5cf85ffb25b3a5f041b02fe2 SHA512 d36d668a636222ce6394eca2598850e68139819543fd3cf0e76301e2a61c9b9303026b49536d1ed1b52f44d5703dc5e4247df786e0b4a704b28872e0a4a71b27
diff --git a/net-misc/youtube-dl/youtube-dl-2020.01.24.ebuild b/net-misc/youtube-dl/youtube-dl-2020.01.24.ebuild
new file mode 100644
index 000000000000..faa91ea76c9b
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2020.01.24.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{2_7,3_{6,7,8}})
+inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://github.com/ytdl-org/youtube-dl/"
+SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+LICENSE="public-domain"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+SLOT="0"
+IUSE="test"
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ || (
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/flake8[${PYTHON_USEDEP}]
+ )
+"
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake offlinetest
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins ${PN}.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+ rm -r "${ED}"/usr/share/doc/youtube_dl || die
+}
+
+pkg_postinst() {
+ elog "${PN}(1) / https://bugs.gentoo.org/355661 /"
+ elog "https://github.com/rg3/${PN}/blob/master/README.md#faq :"
+ elog
+ elog "${PN} works fine on its own on most sites. However, if you want"
+ elog "to convert video/audio, you'll need avconf (media-video/libav) or"
+ elog "ffmpeg (media-video/ffmpeg). On some sites - most notably YouTube -"
+ elog "videos can be retrieved in a higher quality format without sound."
+ elog "${PN} will detect whether avconv/ffmpeg is present and"
+ elog "automatically pick the best option."
+ elog
+ elog "Videos or video formats streamed via RTMP protocol can only be"
+ elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
+ elog
+ elog "Downloading MMS and RTSP videos requires either mplayer"
+ elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
+ elog
+ elog "If you want ${PN} to embed thumbnails from the metadata into the"
+ elog "resulting MP4 files, consider installing media-video/atomicparsley"
+}