summaryrefslogtreecommitdiff
path: root/net-misc/wol/wol-0.7.1-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/wol/wol-0.7.1-r3.ebuild')
-rw-r--r--net-misc/wol/wol-0.7.1-r3.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/net-misc/wol/wol-0.7.1-r3.ebuild b/net-misc/wol/wol-0.7.1-r3.ebuild
index 4b4ba0165cd9..3bcd9963ecdb 100644
--- a/net-misc/wol/wol-0.7.1-r3.ebuild
+++ b/net-misc/wol/wol-0.7.1-r3.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit toolchain-funcs
+inherit autotools toolchain-funcs
DESCRIPTION="Implements Wake On LAN (Magic Paket) functionality in a small program"
HOMEPAGE="http://ahh.sourceforge.net/wol/"
@@ -14,7 +14,18 @@ SLOT="0"
KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~sparc x86"
IUSE="nls"
-PATCHES=( "${FILESDIR}/${P}-musl.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-musl.patch"
+ "${FILESDIR}/${P}-Fix-config.h-test-consumption.patch"
+ "${FILESDIR}/${P}-Fix-malloc-detection.patch"
+)
+
+src_prepare() {
+ default
+
+ # bug #874420
+ eautoreconf
+}
src_configure() {
local myeconfargs=(