summaryrefslogtreecommitdiff
path: root/net-misc/wget2/wget2-2.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/wget2/wget2-2.0.0.ebuild')
-rw-r--r--net-misc/wget2/wget2-2.0.0.ebuild16
1 files changed, 3 insertions, 13 deletions
diff --git a/net-misc/wget2/wget2-2.0.0.ebuild b/net-misc/wget2/wget2-2.0.0.ebuild
index 2926f4837238..facb07871d08 100644
--- a/net-misc/wget2/wget2-2.0.0.ebuild
+++ b/net-misc/wget2/wget2-2.0.0.ebuild
@@ -3,8 +3,6 @@
EAPI=7
-inherit autotools
-
DESCRIPTION="GNU Wget2 is a file and recursive website downloader"
HOMEPAGE="https://gitlab.com/gnuwget/wget2"
SRC_URI="mirror://gnu/wget/${P}.tar.gz"
@@ -48,17 +46,6 @@ BDEPEND="
RESTRICT="!test? ( test )"
-PATCHES=(
- # Upstream attempts to be "smart" by calling ldconfig in
- # install-exec-hook
- "${FILESDIR}"/${PN}-1.99.2-remove_ldconfig_call.patch
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
src_configure() {
local myeconfargs=(
--disable-static
@@ -79,6 +66,9 @@ src_configure() {
$(use_with pcre libpcre2)
$(use_with psl libpsl)
$(use_with zlib)
+
+ # Avoid calling ldconfig
+ LDCONFIG=:
)
econf "${myeconfargs[@]}"
}