summaryrefslogtreecommitdiff
path: root/net-misc/wget/wget-1.21.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/wget/wget-1.21.1.ebuild')
-rw-r--r--net-misc/wget/wget-1.21.1.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/net-misc/wget/wget-1.21.1.ebuild b/net-misc/wget/wget-1.21.1.ebuild
index 2d15744b57f8..dfd4fce484b8 100644
--- a/net-misc/wget/wget-1.21.1.ebuild
+++ b/net-misc/wget/wget-1.21.1.ebuild
@@ -75,6 +75,12 @@ src_configure() {
# the included gnutls -- force ioctl.h to include this header
[[ ${CHOST} == *-solaris* ]] && append-cppflags -DBSD_COMP=1
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # https://lists.gnu.org/archive/html/bug-findutils/2021-01/msg00050.html
+ # https://lists.gnu.org/archive/html/bug-findutils/2021-01/msg00051.html
+ append-cppflags '-D__nonnull\(X\)='
+ fi
+
if use static ; then
append-ldflags -static
tc-export PKG_CONFIG