summaryrefslogtreecommitdiff
path: root/net-misc/unison/unison-2.51.3_p20201127.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/unison/unison-2.51.3_p20201127.ebuild')
-rw-r--r--net-misc/unison/unison-2.51.3_p20201127.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/net-misc/unison/unison-2.51.3_p20201127.ebuild b/net-misc/unison/unison-2.51.3_p20201127.ebuild
index a035fe9b7214..f63e304f3ab9 100644
--- a/net-misc/unison/unison-2.51.3_p20201127.ebuild
+++ b/net-misc/unison/unison-2.51.3_p20201127.ebuild
@@ -39,7 +39,7 @@ src_prepare() {
}
src_compile() {
- local myconf="all"
+ local myconf
if use threads; then
myconf="$myconf THREADS=true"
@@ -57,13 +57,12 @@ src_compile() {
use ocamlopt || myconf="$myconf NATIVE=false"
- # Discard cflags as it will try to pass them to ocamlc...
- emake $myconf CFLAGS=""
-
if use doc; then
- myconf="$myconf docs HEVEA=false"
- emake $myconf CFLAGS=""
+ VARTEXFONTS="${T}/fonts" emake $myconf CFLAGS="" HEVEA=false docs
fi
+
+ # Discard cflags as it will try to pass them to ocamlc...
+ emake $myconf CFLAGS="" src
}
src_test() {