summaryrefslogtreecommitdiff
path: root/net-misc/tigervnc/tigervnc-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/tigervnc/tigervnc-9999.ebuild')
-rw-r--r--net-misc/tigervnc/tigervnc-9999.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/net-misc/tigervnc/tigervnc-9999.ebuild b/net-misc/tigervnc/tigervnc-9999.ebuild
index fc6cb7d77a07..891ae952cf7e 100644
--- a/net-misc/tigervnc/tigervnc-9999.ebuild
+++ b/net-misc/tigervnc/tigervnc-9999.ebuild
@@ -6,7 +6,8 @@ EAPI=8
CMAKE_IN_SOURCE_BUILD=1
inherit autotools cmake flag-o-matic java-pkg-opt-2 optfeature systemd xdg
-XSERVER_VERSION="21.1.1"
+XSERVER_VERSION="21.1.8"
+XSERVER_PATCH_VERSION="21.1.1"
DESCRIPTION="Remote desktop viewer display system"
HOMEPAGE="https://tigervnc.org"
@@ -71,13 +72,14 @@ COMMON_DEPEND="
)
"
RDEPEND="${COMMON_DEPEND}
- java? ( virtual/jre:1.8 )
+ java? ( >=virtual/jre-1.8:* )
server? (
dev-lang/perl
sys-process/psmisc
)
"
DEPEND="${COMMON_DEPEND}
+ java? ( >=virtual/jdk-1.8:* )
drm? ( x11-libs/libdrm )
server? (
media-fonts/font-util
@@ -101,7 +103,6 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.12.0-xsession-path.patch
"${FILESDIR}"/${PN}-1.12.80-disable-server-and-pam.patch
)
-[[ ${PV} == *9999 ]] && PATCHES+=( "${FILESDIR}"/${PN}-1.13.80-depend-po-files.patch )
src_unpack() {
if [[ ${PV} == *9999 ]]; then
@@ -121,7 +122,7 @@ src_prepare() {
if use server; then
cd unix/xserver || die
- eapply ../xserver${XSERVER_VERSION}.patch
+ eapply ../xserver${XSERVER_PATCH_VERSION}.patch
eautoreconf
sed -i 's:\(present.h\):../present/\1:' os/utils.c || die
sed -i '/strcmp.*-fakescreenfps/,/^ \}/d' os/utils.c || die