summaryrefslogtreecommitdiff
path: root/net-misc/sysrepo/sysrepo-2.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/sysrepo/sysrepo-2.0.1.ebuild')
-rw-r--r--net-misc/sysrepo/sysrepo-2.0.1.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/net-misc/sysrepo/sysrepo-2.0.1.ebuild b/net-misc/sysrepo/sysrepo-2.0.1.ebuild
deleted file mode 100644
index aba7132d49a5..000000000000
--- a/net-misc/sysrepo/sysrepo-2.0.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="YANG-based configuration and operational state data store"
-HOMEPAGE="https://www.sysrepo.org"
-SRC_URI="https://github.com/sysrepo/sysrepo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=net-libs/libyang-2.0.3:="
-DEPEND="${RDEPEND}"
-BDEPEND="doc? ( app-doc/doxygen[dot] )"
-
-PATCHES=( "${FILESDIR}"/${P}-cmake.patch )
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_TESTS=$(usex test)
- )
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
-
- use doc && cmake_src_compile doc
-}
-
-src_install() {
- cmake_src_install
-
- use doc && dodoc -r doc/.
-}