summaryrefslogtreecommitdiff
path: root/net-misc/samplicator/samplicator-1.3.6-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/samplicator/samplicator-1.3.6-r1.ebuild')
-rw-r--r--net-misc/samplicator/samplicator-1.3.6-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-misc/samplicator/samplicator-1.3.6-r1.ebuild b/net-misc/samplicator/samplicator-1.3.6-r1.ebuild
new file mode 100644
index 000000000000..1d2a557d88d1
--- /dev/null
+++ b/net-misc/samplicator/samplicator-1.3.6-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="UDP packets forwarder and duplicator"
+HOMEPAGE="https://github.com/sleinen/samplicator"
+SRC_URI="https://github.com/sleinen/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="Artistic GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ acct-group/samplicator
+ acct-user/samplicator
+"
+
+src_install() {
+ # Install and copy documentation
+ default
+
+ # Install Gentoo init script and its config
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+
+ # Install manual page
+ doman "${FILESDIR}"/${PN}.8
+}
+
+pkg_postinst() {
+ ewarn ""
+ ewarn "Don't specify the receiver on the command line, because it will get all packets."
+ ewarn "Instead of this, specify it in a config file; defined in such way it will only get packets with a matching source."
+ ewarn ""
+
+ einfo "For every receiver type create a file in directory /etc/${PN} (see example below)"
+ einfo "and specify the path to it in variable CONFIG of the corresponding initscript config file in /etc/conf.d/"
+ einfo ""
+ einfo "Receiver config examples: "
+ einfo ""
+ einfo " /etc/${PN}/netflow:"
+ einfo " 10.0.0.0/255.0.0.0:1.1.1.1/9996 2.2.2.2/9996 3.3.3.3/9996"
+ einfo ""
+ einfo " /etc/${PN}/syslog:"
+ einfo " 10.0.0.0/255.255.0.0:2.2.2.2/514 3.3.3.3/514"
+ einfo ""
+ einfo " /etc/${PN}/snmp:"
+ einfo " 10.0.0.0/255.255.255.255:3.3.3.3/162"
+}