summaryrefslogtreecommitdiff
path: root/net-misc/rsync/rsync-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/rsync/rsync-9999.ebuild')
-rw-r--r--net-misc/rsync/rsync-9999.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/net-misc/rsync/rsync-9999.ebuild b/net-misc/rsync/rsync-9999.ebuild
index 4d23490d778c..4dc746f9c96a 100644
--- a/net-misc/rsync/rsync-9999.ebuild
+++ b/net-misc/rsync/rsync-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=8
# Uncomment when introducing a patch which touches configure
#RSYNC_NEEDS_AUTOCONF=1
PYTHON_COMPAT=( python3_{9..11} )
-inherit prefix python-single-r1 systemd
+inherit flag-o-matic prefix python-single-r1 systemd
DESCRIPTION="File transfer program to keep remote files into sync"
HOMEPAGE="https://rsync.samba.org/"
@@ -76,6 +76,10 @@ else
BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-waynedavison )"
fi
+PATCHES=(
+ "${FILESDIR}"/${P}-flist-memcmp-ub.patch
+)
+
pkg_setup() {
# - USE=examples needs Python itself at runtime, but nothing else
# - 9999 needs commonmark at build time
@@ -121,6 +125,14 @@ src_configure() {
$(use_enable zstd)
)
+ # https://github.com/WayneD/rsync/pull/428
+ if is-flagq -fsanitize=undefined ; then
+ sed -E -i \
+ -e 's:#define CAREFUL_ALIGNMENT (0|1):#define CAREFUL_ALIGNMENT 1:' \
+ byteorder.h || die
+ append-flags -DCAREFUL_ALIGNMENT
+ fi
+
econf "${myeconfargs[@]}"
}