summaryrefslogtreecommitdiff
path: root/net-misc/rclone/rclone-1.50.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/rclone/rclone-1.50.0.ebuild')
-rw-r--r--net-misc/rclone/rclone-1.50.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-misc/rclone/rclone-1.50.0.ebuild b/net-misc/rclone/rclone-1.50.0.ebuild
new file mode 100644
index 000000000000..8bec0f181760
--- /dev/null
+++ b/net-misc/rclone/rclone-1.50.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit golang-build bash-completion-r1
+EGO_PN="github.com/rclone/${PN}"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64 ~arm ~x86"
+ EGIT_COMMIT="v${PV}"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="A program to sync files to and from various cloud storage providers"
+HOMEPAGE="https://rclone.org/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dobin ${PN}
+ doman src/${EGO_PN}/${PN}.1
+ dodoc src/${EGO_PN}/README.md
+
+ ./rclone genautocomplete bash ${PN}.bash || die
+ newbashcomp ${PN}.bash ${PN}
+
+ ./rclone genautocomplete zsh ${PN}.zsh || die
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+}