summaryrefslogtreecommitdiff
path: root/net-misc/r8168/r8168-8.045.08.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/r8168/r8168-8.045.08.ebuild')
-rw-r--r--net-misc/r8168/r8168-8.045.08.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-misc/r8168/r8168-8.045.08.ebuild b/net-misc/r8168/r8168-8.045.08.ebuild
new file mode 100644
index 000000000000..aefe5b84ce64
--- /dev/null
+++ b/net-misc/r8168/r8168-8.045.08.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info linux-mod eutils
+
+DESCRIPTION="r8168 driver for Realtek 8111/8168 PCI-E NICs"
+HOMEPAGE="http://www.realtek.com.tw"
+SRC_URI="http://12244.wpc.azureedge.net/8012244/drivers/rtdrivers/cn/nic/0010-${P}.tar.bz2 -> ${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+MODULE_NAMES="r8168(net:${S}/src)"
+BUILD_TARGETS="modules"
+
+CONFIG_CHECK="!R8169"
+ERROR_R8169="${P} requires Realtek 8169 PCI Gigabit Ethernet adapter (CONFIG_R8169) to be DISABLED"
+
+PATCHES=(
+ "${FILESDIR}"/linux-4.15-2.patch
+)
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERNELDIR=${KV_DIR}"
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc README
+}