summaryrefslogtreecommitdiff
path: root/net-misc/proxytunnel
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/proxytunnel')
-rw-r--r--net-misc/proxytunnel/Manifest3
-rw-r--r--net-misc/proxytunnel/files/proxytunnel-1.9.1-gcc-10.patch128
-rw-r--r--net-misc/proxytunnel/proxytunnel-1.9.1-r2.ebuild3
3 files changed, 132 insertions, 2 deletions
diff --git a/net-misc/proxytunnel/Manifest b/net-misc/proxytunnel/Manifest
index b9b60c9684e7..507b94d72bd3 100644
--- a/net-misc/proxytunnel/Manifest
+++ b/net-misc/proxytunnel/Manifest
@@ -1,6 +1,7 @@
+AUX proxytunnel-1.9.1-gcc-10.patch 4076 BLAKE2B 13dcff92f5c440430b03b02abd2d3068fa1b95cd67d5830ab99ac077ca24b333dbfd7423d37c7e6cba8d92f820cc7c1ea5d407ac12f3ddd367fe48519113a310 SHA512 c031b884ee929cdae87fb03846a6f0a99b38fbea96c3fbbe94bd176d873e73a15f1a914795f85c9fb6cd107ec117e38dbce93a6aaa256ca516b41a0bd74f6929
AUX proxytunnel-allowTLS.patch 592 BLAKE2B 2c48bb1a1c2e2374043d9bc73e653a5f87f5bbda6a64a5572cbe3bdafe533205f619b7248c8f7b6cecf7de8c72940a6ccf64e054c5419e9ba656f773e9d7d346 SHA512 67b0103054c56c69cd9c0d1aa144498151f105004b400bcdbbb3df519d37424630554e101e5617faf075fd978edddfc4d06cca7524c51e28cd33c1165b6a22f9
DIST proxytunnel-1.9.1.tar.gz 48025 BLAKE2B 5a844d8fdbb9a1eae9c40c7621086b873ae89813b7c596da4416efcb777a8110ad7d224a0efa2e193cfbbb82dbfe69d44d4dd36db080b8e902630a464a85b953 SHA512 819dd11bc13fc279d2d475b89909c0eea414ff71d772d4bfed742dd8d425669dc502f2c22d983bb8c58e426a2bc7209526cb21492ca5f8e92ea1b9ea961fcfdc
EBUILD proxytunnel-1.9.1-r1.ebuild 1048 BLAKE2B 3e094ffb84e324cb426afb819cdf6ab0be3ce187fa792079a7b19b6df96e70ea2004d19d28e87b70fccb2cfb7f34c16d63cbcad6bbb778f52bc9f75f98445d55 SHA512 795116f573c2692ce2776b7cb4ccd6e3c19a88650750bdd2f87d5b5e8bdcf65efb08ed75dbbb93046ad85d4d80fc6072b4c721d80bca81ce0d3493206b9837d0
-EBUILD proxytunnel-1.9.1-r2.ebuild 1144 BLAKE2B 235a78aecce1da4cb61be6cb8955994c4d20d1ba3c28855d88b0c53c1547d39c92e67a506f940a8bfe4ebf02f1b673c9f33c28b58cbc506455df636a79f8e450 SHA512 cc5dcbcdbef3b73219c3b95ebe173965398e537e9bfbe2bf8e20d7415888b8ac40fb69f6bcfaeec00d50a3a7b2b317e1be71ca199b374496a818a71a2d7b7c09
+EBUILD proxytunnel-1.9.1-r2.ebuild 1177 BLAKE2B 6fc1c7d33d2acd73828338bfa1ae44a89162988db8214c9371316d53f92c217454627cabf31191489330b5d4104d2c59247ab0931f3709e26660c4f6dd8da399 SHA512 9a3e1517dd97ad8a702e9d184bf1f4bb2d0a0a023760b52b0011f1a94929c142e87935e4ff6974ad8db0837c1fec33bf302ed206b1b13515e444e629741ba290
EBUILD proxytunnel-9999.ebuild 1096 BLAKE2B 5bb10d54b3fb48b972d5e9907a4a8bb69a6c9619668c5b8e55e74db108020bd8eff1f3acf8e1bdfc58153952751a4071652a3168e0062f6ad253589cabf2da8d SHA512 265cac79e95bfaa8f639114a03b4f79f73f83450328259dd3ddfddf63b575a35536009bfd4ae39c1716b973644a8bd78aa28b3a229c74edb47bdc3ff10eaa215
MISC metadata.xml 717 BLAKE2B da3b819d7e0caeee376359837cf0a6294eee0363ad857369816fbf595e6add90666feeea356a9864d71a3987f7393ac7483bd4fe800bae67364291da420a2c39 SHA512 ecf80d876bccd3c2c98cb6a46e543e6adbe5a52a1666b6678cd86def313593d5200189f67cec5d85150e7a308139089786c416ee0a2d6bfe58d800b0fc7a18da
diff --git a/net-misc/proxytunnel/files/proxytunnel-1.9.1-gcc-10.patch b/net-misc/proxytunnel/files/proxytunnel-1.9.1-gcc-10.patch
new file mode 100644
index 000000000000..a42b8424cca5
--- /dev/null
+++ b/net-misc/proxytunnel/files/proxytunnel-1.9.1-gcc-10.patch
@@ -0,0 +1,128 @@
+https://github.com/proxytunnel/proxytunnel/pull/43
+
+From 517650724dc478dd35ac7c7953b4eb700ccb7273 Mon Sep 17 00:00:00 2001
+From: Paul Howarth <paul@city-fan.org>
+Date: Wed, 22 Jan 2020 21:44:01 +0000
+Subject: [PATCH] Fix global variable declarations/definitions for GCC 10
+ compatibility
+
+This boils down to declaring global variables as "extern" in header files
+and defining them in just one place.
+
+See https://www.gnu.org/software/gcc/gcc-10/porting_to.html
+---
+ Makefile | 1 +
+ globals.c | 41 +++++++++++++++++++++++++++++++++++++++++
+ ntlm.h | 4 ++--
+ proxytunnel.h | 16 ++++++++--------
+ 4 files changed, 52 insertions(+), 10 deletions(-)
+ create mode 100644 globals.c
+
+diff --git a/Makefile b/Makefile
+index 57328e8..ecdaa5f 100644
+--- a/Makefile
++++ b/Makefile
+@@ -63,6 +63,7 @@ OBJ = proxytunnel.o \
+ readpassphrase.o \
+ messages.o \
+ cmdline.o \
++ globals.o \
+ ntlm.o \
+ ptstream.o
+
+diff --git a/globals.c b/globals.c
+new file mode 100644
+index 0000000..fe19db4
+--- /dev/null
++++ b/globals.c
+@@ -0,0 +1,41 @@
++/* Proxytunnel - (C) 2001-2008 Jos Visser / Mark Janssen */
++/* Contact: josv@osp.nl / maniac@maniac.nl */
++
++/*
++ * This program is free software; you can redistribute it and/or modify
++ * it under the terms of the GNU General Public License as published by
++ * the Free Software Foundation; either version 2 of the License, or
++ * (at your option) any later version.
++ *
++ * This program is distributed in the hope that it will be useful,
++ * but WITHOUT ANY WARRANTY; without even the implied warranty of
++ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
++ * GNU General Public License for more details.
++ *
++ * You should have received a copy of the GNU General Public License
++ * along with this program; if not, write to the Free Software
++ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
++ */
++
++/* globals.c */
++
++#include "proxytunnel.h"
++
++/* Globals */
++char *program_name; /* Guess what? */
++int i_am_daemon; /* Also... */
++
++PTSTREAM *stunnel; /* stream representing the socket from us to proxy */
++PTSTREAM *std; /* stream representing stdin/stdout */
++
++/*
++ * All the command line options
++ */
++struct gengetopt_args_info args_info;
++
++char buf[SIZE]; /* Data transfer buffer */
++
++char ntlm_type1_buf[160];
++char ntlm_type3_buf[4096];
++
++// vim:noexpandtab:ts=4
+diff --git a/ntlm.h b/ntlm.h
+index f919368..01a6434 100644
+--- a/ntlm.h
++++ b/ntlm.h
+@@ -26,8 +26,8 @@ void build_ntlm2_response();
+
+ extern int ntlm_challenge;
+
+-char ntlm_type1_buf[160];
+-char ntlm_type3_buf[4096];
++extern char ntlm_type1_buf[160];
++extern char ntlm_type3_buf[4096];
+
+
+ // Below are the flag definitions.
+diff --git a/proxytunnel.h b/proxytunnel.h
+index 593cd7e..aa09a4b 100644
+--- a/proxytunnel.h
++++ b/proxytunnel.h
+@@ -46,21 +46,21 @@ char * readpassphrase(const char *, char *, size_t, int);
+ char * getpass_x(const char *format, ...);
+
+ /* Globals */
+-int read_fd; /* The file descriptor to read from */
+-int write_fd; /* The file destriptor to write to */
+-char *program_name; /* Guess what? */
+-int i_am_daemon; /* Also... */
++extern int read_fd; /* The file descriptor to read from */
++extern int write_fd; /* The file descriptor to write to */
++extern char *program_name; /* Guess what? */
++extern int i_am_daemon; /* Also... */
+
+-PTSTREAM *stunnel; /* stream representing the socket from us to proxy */
+-PTSTREAM *std; /* stream representing stdin/stdout */
++extern PTSTREAM *stunnel; /* stream representing the socket from us to proxy */
++extern PTSTREAM *std; /* stream representing stdin/stdout */
+
+ /*
+ * All the command line options
+ */
+-struct gengetopt_args_info args_info;
++extern struct gengetopt_args_info args_info;
+
+ #define SIZE 65536
+-char buf[SIZE]; /* Data transfer buffer */
++extern char buf[SIZE]; /* Data transfer buffer */
+
+ /*
+ * Small MAX macro
diff --git a/net-misc/proxytunnel/proxytunnel-1.9.1-r2.ebuild b/net-misc/proxytunnel/proxytunnel-1.9.1-r2.ebuild
index eaf7123e2b0c..a8815f6b96e4 100644
--- a/net-misc/proxytunnel/proxytunnel-1.9.1-r2.ebuild
+++ b/net-misc/proxytunnel/proxytunnel-1.9.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -22,6 +22,7 @@ BDEPEND="virtual/pkgconfig"
DOCS=( CHANGES CREDITS INSTALL KNOWN_ISSUES LICENSE.txt README RELNOTES TODO )
PATCHES=(
"${FILESDIR}"/${PN}-allowTLS.patch
+ "${FILESDIR}"/${P}-gcc-10.patch
)
if [[ ${PV} == *9999 ]] ; then