summaryrefslogtreecommitdiff
path: root/net-misc/proxychains/proxychains-4.12-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/proxychains/proxychains-4.12-r1.ebuild')
-rw-r--r--net-misc/proxychains/proxychains-4.12-r1.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/net-misc/proxychains/proxychains-4.12-r1.ebuild b/net-misc/proxychains/proxychains-4.12-r1.ebuild
deleted file mode 100644
index 65dd3aabd8c7..000000000000
--- a/net-misc/proxychains/proxychains-4.12-r1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-MY_PN=${PN}-ng
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="force any tcp connections to flow through a proxy (or proxy chain)"
-HOMEPAGE="https://github.com/rofl0r/proxychains-ng/"
-SRC_URI="https://github.com/rofl0r/${MY_PN}/releases/download/v${PV}/${MY_P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ~sparc x86"
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
-
-src_prepare() {
- default
- sed -i "s/^\(LDSO_SUFFIX\).*/\1 = so.${PV}/" Makefile || die
- tc-export CC
-}
-
-src_configure() {
- # not autotools
- ./configure \
- --prefix="${EPREFIX}"/usr \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --sysconfdir="${EPREFIX}"/etc \
- || die
-}
-
-src_install() {
- dobin ${PN}
- dodoc AUTHORS README TODO
-
- dolib.so lib${PN}.so.${PV}
- dosym lib${PN}.so.${PV} /usr/$(get_libdir)/lib${PN}.so.${PV:0:1}
- dosym lib${PN}.so.${PV} /usr/$(get_libdir)/lib${PN}.so
-
- insinto /etc
- doins src/${PN}.conf
-}