summaryrefslogtreecommitdiff
path: root/net-misc/openssh/openssh-8.3_p1-r5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/openssh/openssh-8.3_p1-r5.ebuild')
-rw-r--r--net-misc/openssh/openssh-8.3_p1-r5.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/net-misc/openssh/openssh-8.3_p1-r5.ebuild b/net-misc/openssh/openssh-8.3_p1-r5.ebuild
index 86300b9d8105..fffc55544f4e 100644
--- a/net-misc/openssh/openssh-8.3_p1-r5.ebuild
+++ b/net-misc/openssh/openssh-8.3_p1-r5.ebuild
@@ -290,6 +290,13 @@ src_configure() {
use static && append-ldflags -static
use xmss && append-cflags -DWITH_XMSS
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ # Solaris' glob.h doesn't have things like GLOB_TILDE, configure
+ # doesn't check for this, so force the replacement to be put in
+ # place
+ append-cppflags -DBROKEN_GLOB
+ fi
+
local myconf=(
--with-ldflags="${LDFLAGS}"
--disable-strip