summaryrefslogtreecommitdiff
path: root/net-misc/networkmanager/networkmanager-1.44.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/networkmanager/networkmanager-1.44.0-r1.ebuild')
-rw-r--r--net-misc/networkmanager/networkmanager-1.44.0-r1.ebuild16
1 files changed, 3 insertions, 13 deletions
diff --git a/net-misc/networkmanager/networkmanager-1.44.0-r1.ebuild b/net-misc/networkmanager/networkmanager-1.44.0-r1.ebuild
index 47c2023fc20f..a281df555cd2 100644
--- a/net-misc/networkmanager/networkmanager-1.44.0-r1.ebuild
+++ b/net-misc/networkmanager/networkmanager-1.44.0-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
GNOME_ORG_MODULE="NetworkManager"
PYTHON_COMPAT=( python3_{10..12} )
-inherit flag-o-matic gnome.org linux-info meson-multilib python-any-r1 readme.gentoo-r1 systemd toolchain-funcs udev vala virtualx
+inherit gnome.org linux-info meson-multilib python-any-r1 readme.gentoo-r1 systemd udev vala virtualx
DESCRIPTION="A set of co-operative tools that make networking simple and straightforward"
HOMEPAGE="https://wiki.gnome.org/Projects/NetworkManager"
@@ -13,7 +13,7 @@ HOMEPAGE="https://wiki.gnome.org/Projects/NetworkManager"
LICENSE="GPL-2+ LGPL-2.1+"
SLOT="0"
-IUSE="audit bluetooth +concheck connection-sharing debug dhclient dhcpcd elogind gnutls +gtk-doc +introspection iptables iwd psl libedit lto +nss nftables +modemmanager ofono ovs policykit +ppp resolvconf selinux syslog systemd teamd test +tools vala +wext +wifi"
+IUSE="audit bluetooth +concheck connection-sharing debug dhclient dhcpcd elogind gnutls +gtk-doc +introspection iptables iwd psl libedit +nss nftables +modemmanager ofono ovs policykit +ppp resolvconf selinux syslog systemd teamd test +tools vala +wext +wifi"
RESTRICT="!test? ( test )"
REQUIRED_USE="
@@ -143,12 +143,6 @@ pkg_setup() {
if use introspection || use test; then
python-any-r1_pkg_setup
fi
-
- # bug 809695
- if tc-is-clang && use lto; then
- eerror "Clang does not support -flto-partition"
- die "Please use gcc or turn off USE=lto flag when building with clang"
- fi
}
src_prepare() {
@@ -173,8 +167,6 @@ meson_nm_native_program() {
}
multilib_src_configure() {
- filter-lto
-
local emesonargs=(
--localstatedir="${EPREFIX}/var"
@@ -239,8 +231,6 @@ multilib_src_configure() {
-Dld_gc=false
$(meson_native_use_bool psl libpsl)
-Dqt=false
-
- $(meson_use lto b_lto)
)
if multilib_is_native_abi && use systemd; then