summaryrefslogtreecommitdiff
path: root/net-misc/mrouted/mrouted-4.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/mrouted/mrouted-4.4.ebuild')
-rw-r--r--net-misc/mrouted/mrouted-4.4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-misc/mrouted/mrouted-4.4.ebuild b/net-misc/mrouted/mrouted-4.4.ebuild
new file mode 100644
index 000000000000..97fd56dd2d0c
--- /dev/null
+++ b/net-misc/mrouted/mrouted-4.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs systemd
+
+DESCRIPTION="IP multicast routing daemon"
+HOMEPAGE="https://troglobit.com/projects/mrouted/"
+SRC_URI="https://github.com/troglobit/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="Stanford GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="rsrr test"
+
+# Needs unshare
+RESTRICT="!test? ( test ) test"
+
+BDEPEND="virtual/pkgconfig
+ virtual/yacc"
+
+src_configure() {
+ tc-export CC CXX
+
+ econf \
+ $(usev rsrr --enable-rsrr) \
+ $(use_enable test)
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ default
+
+ insinto /etc
+ doins mrouted.conf
+
+ newinitd "${FILESDIR}"/mrouted.rc mrouted
+ systemd_dounit mrouted.service
+}