summaryrefslogtreecommitdiff
path: root/net-misc/kea/kea-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/kea/kea-9999.ebuild')
-rw-r--r--net-misc/kea/kea-9999.ebuild31
1 files changed, 22 insertions, 9 deletions
diff --git a/net-misc/kea/kea-9999.ebuild b/net-misc/kea/kea-9999.ebuild
index aca4fe99e606..56fe907cd840 100644
--- a/net-misc/kea/kea-9999.ebuild
+++ b/net-misc/kea/kea-9999.ebuild
@@ -10,31 +10,38 @@ MY_P="${PN}-${MY_PV}"
DESCRIPTION="High-performance production grade DHCPv4 & DHCPv6 server"
HOMEPAGE="https://www.isc.org/kea/"
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit autotools fcaps python-single-r1 systemd tmpfiles
if [[ ${PV} = 9999* ]] ; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/isc-projects/kea.git"
+ EGIT_REPO_URI="https://gitlab.isc.org/isc-projects/kea.git"
else
SRC_URI="ftp://ftp.isc.org/isc/kea/${MY_P}.tar.gz
ftp://ftp.isc.org/isc/kea/${MY_PV}/${MY_P}.tar.gz"
- # Odd minor version = development release
+ # odd minor version = development release
if [[ $(( $(ver_cut 2) % 2 )) -ne 1 ]] ; then
- [[ "${PV}" == *_beta* ]] || [[ "${PV}" == *_rc* ]] || \
- KEYWORDS="~amd64 ~arm64 ~x86"
+ if ! [[ "${PV}" == *_beta* || "${PV}" == *_rc* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ fi
fi
fi
LICENSE="ISC BSD SSLeay GPL-2" # GPL-2 only for init script
SLOT="0"
-IUSE="mysql +openssl postgres +samples shell test"
+IUSE="debug doc mysql +openssl postgres +samples shell test"
RESTRICT="!test? ( test )"
COMMON_DEPEND="
dev-libs/boost:=
dev-libs/log4cplus
+ doc? (
+ $(python_gen_cond_dep '
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ ')
+ )
mysql? ( dev-db/mysql-connector-c )
!openssl? ( dev-libs/botan:2= )
openssl? ( dev-libs/openssl:0= )
@@ -54,8 +61,7 @@ REQUIRED_USE="shell? ( ${PYTHON_REQUIRED_USE} )"
S="${WORKDIR}/${MY_P}"
PATCHES=(
- "${FILESDIR}"/${PN}-1.8.2-boost-1.77.0.patch
- "${FILESDIR}"/${PN}-1.9.10-gtest.patch
+ "${FILESDIR}"/${PN}-2.2.0-openssl-version.patch
)
pkg_setup() {
@@ -64,7 +70,10 @@ pkg_setup() {
src_prepare() {
default
- # Brand the version with Gentoo
+
+ cp "${FILESDIR}"/ax_gtest.m4 "${S}"/m4macros/ax_gtest.m4 || die 'Replace gtest m4 macro failed'
+
+ # brand the version with Gentoo
sed -i \
-e "s/AC_INIT(kea,${PV}.*, kea-dev@lists.isc.org)/AC_INIT([kea], [${PVR}-gentoo], [kea-dev@lists.isc.org])/g" \
configure.ac || die
@@ -79,12 +88,16 @@ src_prepare() {
src_configure() {
local myeconfargs=(
--disable-install-configurations
+ --disable-rpath
--disable-static
--enable-generate-messages
--enable-perfdhcp
--localstatedir="${EPREFIX}/var"
--runstatedir="${EPREFIX}/run"
--without-werror
+ --with-log4cplus
+ $(use_enable debug)
+ $(use_enable doc generate-docs)
$(use_enable test gtest)
$(use_enable shell)
$(use_with mysql)