summaryrefslogtreecommitdiff
path: root/net-misc/kafkacat/kafkacat-1.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/kafkacat/kafkacat-1.5.0.ebuild')
-rw-r--r--net-misc/kafkacat/kafkacat-1.5.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-misc/kafkacat/kafkacat-1.5.0.ebuild b/net-misc/kafkacat/kafkacat-1.5.0.ebuild
new file mode 100644
index 000000000000..911a01bcf838
--- /dev/null
+++ b/net-misc/kafkacat/kafkacat-1.5.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Generic command line non-JVM Apache Kafka producer and consumer"
+HOMEPAGE="https://github.com/edenhill/kafkacat"
+SRC_URI="https://github.com/edenhill/kafkacat/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+json"
+
+DEPEND=">=dev-libs/librdkafka-0.9.4
+ json? ( dev-libs/yajl )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf $(use_enable json) --cc=$(tc-getCC)
+}
+
+src_install() {
+ default
+ doman ${PN}.1
+}