summaryrefslogtreecommitdiff
path: root/net-misc/ices/files
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/ices/files')
-rw-r--r--net-misc/ices/files/ices-2.0.2-gettimeofday.patch15
-rw-r--r--net-misc/ices/files/ices-2.0.2-libogg-test.patch17
2 files changed, 32 insertions, 0 deletions
diff --git a/net-misc/ices/files/ices-2.0.2-gettimeofday.patch b/net-misc/ices/files/ices-2.0.2-gettimeofday.patch
new file mode 100644
index 000000000000..ba5e7ca1c4a5
--- /dev/null
+++ b/net-misc/ices/files/ices-2.0.2-gettimeofday.patch
@@ -0,0 +1,15 @@
+Uses gettimeofday but won't include sys/time.h without HAVE_SYS_TIME_H
+leading to failure with -Werror=implicit-function-declaration (clang16).
+
+sys/timeb.h is for deprecated ftime() and should not be used.
+
+https://bugs.gentoo.org/870973
+--- a/configure.in
++++ b/configure.in
+@@ -51,5 +51,5 @@
+ dnl Checks for header files.
+ AC_HEADER_STDC
+-AC_CHECK_HEADERS([stropts.h sys/timeb.h sys/select.h])
++AC_CHECK_HEADERS([stropts.h sys/time.h sys/select.h])
+
+ dnl ================================================================
diff --git a/net-misc/ices/files/ices-2.0.2-libogg-test.patch b/net-misc/ices/files/ices-2.0.2-libogg-test.patch
new file mode 100644
index 000000000000..78a334b93096
--- /dev/null
+++ b/net-misc/ices/files/ices-2.0.2-libogg-test.patch
@@ -0,0 +1,17 @@
+clang/lld will try to use the given -L/usr/lib + 32bit files and potentially
+fail the the test on 64bit, carries on but leads to ogg underlinking.
+
+Quickfix, ideally this should use pkg-config and hard-fail if not found.
+
+https://bugs.gentoo.org/740794
+--- a/m4/ogg.m4
++++ b/m4/ogg.m4
+@@ -24,8 +24,4 @@
+ fi
+
+-XIPH_GCC_WARNING([-I$ogg_prefix/include],,
+- [ OGG_CFLAGS="-I$ogg_prefix/include"
+- OGG_LDFLAGS="-L$ogg_prefix/lib"
+- ])
+ AC_CACHE_CHECK([for libogg], xt_cv_lib_ogg,
+ [dnl