summaryrefslogtreecommitdiff
path: root/net-misc/httpie/httpie-2.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/httpie/httpie-2.5.0.ebuild')
-rw-r--r--net-misc/httpie/httpie-2.5.0.ebuild22
1 files changed, 2 insertions, 20 deletions
diff --git a/net-misc/httpie/httpie-2.5.0.ebuild b/net-misc/httpie/httpie-2.5.0.ebuild
index b2e48e8373fa..00420956f69e 100644
--- a/net-misc/httpie/httpie-2.5.0.ebuild
+++ b/net-misc/httpie/httpie-2.5.0.ebuild
@@ -10,14 +10,12 @@ PYTHON_REQ_USE="ssl(+)"
inherit bash-completion-r1 distutils-r1
DESCRIPTION="Modern command line HTTP client"
-HOMEPAGE="https://httpie.org/ https://pypi.org/project/httpie/"
-SRC_URI="https://github.com/jakubroztocil/httpie/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://httpie.io/ https://pypi.org/project/httpie/"
+SRC_URI="https://github.com/httpie/httpie/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="
dev-python/defusedxml[${PYTHON_USEDEP}]
@@ -28,7 +26,6 @@ RDEPEND="
BDEPEND="
test? (
${RDEPEND}
- dev-python/mock[${PYTHON_USEDEP}]
dev-python/pyopenssl[${PYTHON_USEDEP}]
dev-python/pytest-httpbin[${PYTHON_USEDEP}]
dev-python/responses[${PYTHON_USEDEP}]
@@ -37,21 +34,6 @@ BDEPEND="
distutils_enable_tests pytest
-python_test() {
- local skipped_tests=()
-
- skipped_tests+=(
- tests/test_uploads.py::test_chunked_json
- tests/test_uploads.py::test_chunked_form
- tests/test_uploads.py::test_chunked_stdin
- tests/test_uploads.py::TestMultipartFormDataFileUpload::test_multipart_chunked
- tests/test_uploads.py::TestRequestBodyFromFilePath::test_request_body_from_file_by_path_chunked
- tests/test_tokens.py::test_verbose_chunked
- )
-
- pytest -v ${skipped_tests[@]/#/--deselect } || die "Tests failed with ${EPYTHON}"
-}
-
python_install_all() {
newbashcomp extras/httpie-completion.bash http
insinto /usr/share/fish/vendor_completions.d