summaryrefslogtreecommitdiff
path: root/net-misc/freerdp/freerdp-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/freerdp/freerdp-9999.ebuild')
-rw-r--r--net-misc/freerdp/freerdp-9999.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/net-misc/freerdp/freerdp-9999.ebuild b/net-misc/freerdp/freerdp-9999.ebuild
index 1ca075a5d92c..48ee51c92773 100644
--- a/net-misc/freerdp/freerdp-9999.ebuild
+++ b/net-misc/freerdp/freerdp-9999.ebuild
@@ -1,18 +1,21 @@
-# Copyright 2011-2019 Gentoo Authors
+# Copyright 2011-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit cmake
-if [[ ${PV} != 9999 ]]; then
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/FreeRDP/FreeRDP.git"
+ case ${PV} in
+ 2.*) EGIT_BRANCH="stable-2.0";;
+ esac
+else
MY_P=${P/_/-}
S="${WORKDIR}/${MY_P}"
SRC_URI="https://pub.freerdp.com/releases/${MY_P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-else
- inherit git-r3
- EGIT_REPO_URI="https://github.com/FreeRDP/FreeRDP.git"
fi
DESCRIPTION="Free implementation of the Remote Desktop Protocol"