summaryrefslogtreecommitdiff
path: root/net-misc/dhcdrop
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/dhcdrop')
-rw-r--r--net-misc/dhcdrop/Manifest5
-rw-r--r--net-misc/dhcdrop/dhcdrop-0.5-r1.ebuild11
-rw-r--r--net-misc/dhcdrop/files/dhcdrop-0.5-lto.patch33
-rw-r--r--net-misc/dhcdrop/metadata.xml4
4 files changed, 44 insertions, 9 deletions
diff --git a/net-misc/dhcdrop/Manifest b/net-misc/dhcdrop/Manifest
index d1208564c328..1a8c54f4842f 100644
--- a/net-misc/dhcdrop/Manifest
+++ b/net-misc/dhcdrop/Manifest
@@ -1,3 +1,4 @@
+AUX dhcdrop-0.5-lto.patch 1208 BLAKE2B d6e762ae33ddc53b0685413cfed499569d774374baa03349c61ed215ea6df935a9b0a8a443af300451f0731590299e5608a745e3c306b2c1f54cc201ecf24125 SHA512 1f761ac00b2038487660e474dc946c7782cc475877c7149d99d0b3a75818bbc6e040313439b7e216a9ac4a71df4a899332060f68f09086fd46c579c84d625893
DIST dhcdrop-0.5.tar.bz2 279218 BLAKE2B e09921633e00b17ca703400bbb50b5551266b80521985c57501e4d94eafca3da6d35c55a78bd98ec832f733e5a11321b2ba56c301aa14e21b0b1fc3e582851b7 SHA512 11ac0ca6dcb65f696936e47e43cfbdd59083b607b26b5d12274cc04577be257dda94e9c27eb0c4aebb40f5f572693478cceb04cc4b5b06bf8882c3001fc46142
-EBUILD dhcdrop-0.5-r1.ebuild 715 BLAKE2B fb01a2f4f786208f2d9b46565b467eca502988abad809f228678d81ee6754ae414b7b35129d1b6690470b580d29968c3ba494695d8cb57a418347102599f3cf8 SHA512 3f0d28f9765cb1545ad5abad5f6bdd98fea24082c7770f2ea6a594aa9cc82b2e5b4122ba381ef5d0d2ff294ebb22fcdda70ff49b9a7c59804be24c7a1ffd592a
-MISC metadata.xml 1027 BLAKE2B 021727be7f378529f86e47e3c32914f9470dd68bb11548c090d86ac89faf57604a9f70aa5cd4e973b68b347df84cf33cdeee90ceb2ff485206c6791e159b7033 SHA512 af52c7a20de8b2f9b06b44d32d5649d7101eaa01a543e72817e24812488828d46d4d6989b93fe5d6862250a398cf358b4f738cfc8685c29a0128a4e2b2b56b08
+EBUILD dhcdrop-0.5-r1.ebuild 794 BLAKE2B de46ec548a6425ced56564be33ea7b2b39fd25a97a4f5d60b76b07545f2edb571819c362adb2cac7ba0a3bde05e442f6abaae030cef1f293909668ed6609d9e4 SHA512 dc42e158791382f0b7e0ea5f0448a72a282d0ed8fe923a73c9ad9dc92666a0b3d72b00b730322d7940725de5f4df3e70e62791fd4a53406131b9d2707f4f44a2
+MISC metadata.xml 919 BLAKE2B 963d92ebd00e4409b7116cd7f0c23c72caad033b7d34c5699abdb5247c4fd64448fbf9b06585c0a0d7bc5c9d2b3633e6782d85d6f13c81d660198b8ea0f95b9f SHA512 e134760036fa9d2736b9ff79ea27a84a93f89ee02dcb9b68747a58b2ca9e8f6b35c2d94949aa65c1e27a0e37221673ed0b41a7e6ed1a3f49a7efe090ca28b633
diff --git a/net-misc/dhcdrop/dhcdrop-0.5-r1.ebuild b/net-misc/dhcdrop/dhcdrop-0.5-r1.ebuild
index 5757f718f4d5..a8e991173aaa 100644
--- a/net-misc/dhcdrop/dhcdrop-0.5-r1.ebuild
+++ b/net-misc/dhcdrop/dhcdrop-0.5-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
DESCRIPTION="Effectively suppresses illegal DHCP servers on the LAN"
HOMEPAGE="http://www.netpatch.ru/dhcdrop.html"
@@ -19,13 +19,18 @@ DEPEND="static? ( net-libs/libpcap[static-libs] )
DOCS=( AUTHORS ChangeLog INSTALL NEWS README )
+PATCHES=(
+ # Fix building with -flto, bug #861608
+ "${FILESDIR}/${P}-lto.patch"
+)
+
src_prepare() {
# Fix building with clang, bug #731694
sed -i \
-e '/^PACKAGE_/s/"//g' \
configure || die
- eapply_user
+ default
}
src_configure() {
diff --git a/net-misc/dhcdrop/files/dhcdrop-0.5-lto.patch b/net-misc/dhcdrop/files/dhcdrop-0.5-lto.patch
new file mode 100644
index 000000000000..240303aa2bf2
--- /dev/null
+++ b/net-misc/dhcdrop/files/dhcdrop-0.5-lto.patch
@@ -0,0 +1,33 @@
+--- a/src/dhcdrop.h 2022-08-23 09:57:15.594679182 +0300
++++ b/src/dhcdrop.h 2022-08-23 09:57:31.034678048 +0300
+@@ -207,9 +207,9 @@
+ inline void replace_semicolons(char * str_ether);
+
+ /* Print ethernet address as hex-digits string */
+-inline void print_ether(const uint8_t * ether_addr);
++static void print_ether(const uint8_t * ether_addr);
+
+ /* Create random ethernet address and store to string 'str_mac_addr' */
+-inline void rand_ether_addr(char * str_mac_addr);
++static void rand_ether_addr(char * str_mac_addr);
+
+ #endif /* ifdef DHCDROP_H*/
+--- a/src/dhcdrop.c 2022-08-23 09:57:09.522679628 +0300
++++ b/src/dhcdrop.c 2022-08-23 09:57:47.810676815 +0300
+@@ -1879,14 +1879,14 @@
+ }
+ }
+
+-inline void print_ether(const uint8_t * ether_addr)
++static void print_ether(const uint8_t * ether_addr)
+ {
+ int i;
+ for(i = 0; i < ETH_ALEN; ++i)
+ printf((i == (ETH_ALEN - 1) ) ? "%02X" :"%02X:", ether_addr[i]);
+ }
+
+-inline void rand_ether_addr(char * str_mac_addr) /* Minimal size of str_mac_addr must be STR_MAC_LEN (18) */
++static void rand_ether_addr(char * str_mac_addr) /* Minimal size of str_mac_addr must be STR_MAC_LEN (18) */
+ {
+ /* Fill first byte */
+ strncat(str_mac_addr, "00:", 3);
diff --git a/net-misc/dhcdrop/metadata.xml b/net-misc/dhcdrop/metadata.xml
index b1b27e6aea57..3a96a89524db 100644
--- a/net-misc/dhcdrop/metadata.xml
+++ b/net-misc/dhcdrop/metadata.xml
@@ -5,10 +5,6 @@
<email>spiderx@spiderx.dp.ua</email>
<name>Vladimir Pavljuchenkov</name>
</maintainer>
- <maintainer type="person">
- <email>pinkbyte@gentoo.org</email>
- <name>Sergey Popov</name>
- </maintainer>
<maintainer type="project" proxied="proxy">
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>