summaryrefslogtreecommitdiff
path: root/net-misc/cocaine-core/cocaine-core-0.9.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/cocaine-core/cocaine-core-0.9.2-r1.ebuild')
-rw-r--r--net-misc/cocaine-core/cocaine-core-0.9.2-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-misc/cocaine-core/cocaine-core-0.9.2-r1.ebuild b/net-misc/cocaine-core/cocaine-core-0.9.2-r1.ebuild
new file mode 100644
index 000000000000..491ca2cd0a9b
--- /dev/null
+++ b/net-misc/cocaine-core/cocaine-core-0.9.2-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils cmake-utils
+
+DESCRIPTION="Cloud platform, core parts"
+HOMEPAGE="http://reverbrain.com/cocaine/"
+SRC_URI="https://github.com/cocaine/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/boost:=
+ <net-libs/zeromq-3
+ dev-libs/libev
+ dev-libs/msgpack
+ dev-libs/libcgroup
+ "
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-boost-1.53.patch" )