summaryrefslogtreecommitdiff
path: root/net-misc/chrony/chrony-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/chrony/chrony-9999.ebuild')
-rw-r--r--net-misc/chrony/chrony-9999.ebuild51
1 files changed, 26 insertions, 25 deletions
diff --git a/net-misc/chrony/chrony-9999.ebuild b/net-misc/chrony/chrony-9999.ebuild
index a9bf2fae2782..e939129a01ac 100644
--- a/net-misc/chrony/chrony-9999.ebuild
+++ b/net-misc/chrony/chrony-9999.ebuild
@@ -38,6 +38,7 @@ RESTRICT=test
S="${WORKDIR}/${P/_/-}"
PATCHES=(
+ "${FILESDIR}"/${PN}-3.5-pool-vendor-gentoo.patch
"${FILESDIR}"/${PN}-3.5-systemd-gentoo.patch
)
@@ -64,34 +65,33 @@ src_configure() {
fi
# not an autotools generated script
- local CHRONY_CONFIGURE="
- ./configure \
- $(use_enable seccomp scfilter) \
- $(usex adns '' --disable-asyncdns) \
- $(usex caps '' --disable-linuxcaps) \
- $(usex cmdmon '' --disable-cmdmon) \
- $(usex ipv6 '' --disable-ipv6) \
- $(usex ntp '' --disable-ntp) \
- $(usex phc '' --disable-phc) \
- $(usex pps '' --disable-pps) \
- $(usex refclock '' --disable-refclock) \
- $(usex rtc '' --disable-rtc) \
- ${CHRONY_EDITLINE} \
- ${EXTRA_ECONF} \
- --chronysockdir=/run/chrony \
- --disable-sechash \
- --docdir=/usr/share/doc/${PF} \
- --mandir=/usr/share/man \
- --prefix=/usr \
- --sysconfdir=/etc/chrony \
+ local myconf=(
+ $(use_enable seccomp scfilter)
+ $(usex adns '' --disable-asyncdns)
+ $(usex caps '' --disable-linuxcaps)
+ $(usex cmdmon '' --disable-cmdmon)
+ $(usex ipv6 '' --disable-ipv6)
+ $(usex ntp '' --disable-ntp)
+ $(usex phc '' --disable-phc)
+ $(usex pps '' --disable-pps)
+ $(usex refclock '' --disable-refclock)
+ $(usex rtc '' --disable-rtc)
+ ${CHRONY_EDITLINE}
+ ${EXTRA_ECONF}
+ --chronysockdir="${EPREFIX}/run/chrony"
+ --disable-sechash
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ --mandir="${EPREFIX}/usr/share/man"
+ --prefix="${EPREFIX}/usr"
+ --sysconfdir="${EPREFIX}/etc/chrony"
--with-pidfile="${EPREFIX}/run/chrony/chronyd.pid"
- --without-nss \
+ --without-nss
--without-tomcrypt
- "
+ )
# print the ./configure call to aid in future debugging
- einfo ${CHRONY_CONFIGURE}
- bash ${CHRONY_CONFIGURE} || die
+ echo bash ./configure "${myconf[@]}" >&2
+ bash ./configure "${myconf[@]}" || die
}
src_compile() {
@@ -118,5 +118,6 @@ src_install() {
insinto /etc/logrotate.d
newins "${FILESDIR}"/chrony-2.4-r1.logrotate chrony
- systemd_dounit examples/chronyd.service
+ systemd_dounit examples/{chronyd,chrony-wait}.service
+ systemd_enable_ntpunit 50-chrony chronyd.service
}