summaryrefslogtreecommitdiff
path: root/net-misc/cadaver/files
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/cadaver/files')
-rw-r--r--net-misc/cadaver/files/cadaver-0.24-autoconf-2.72.patch59
-rw-r--r--net-misc/cadaver/files/cadaver-0.24-link-cflags.patch26
-rw-r--r--net-misc/cadaver/files/cadaver-0.24-neon-0.33.patch15
3 files changed, 100 insertions, 0 deletions
diff --git a/net-misc/cadaver/files/cadaver-0.24-autoconf-2.72.patch b/net-misc/cadaver/files/cadaver-0.24-autoconf-2.72.patch
new file mode 100644
index 000000000000..6051c719e36f
--- /dev/null
+++ b/net-misc/cadaver/files/cadaver-0.24-autoconf-2.72.patch
@@ -0,0 +1,59 @@
+https://github.com/notroj/cadaver/pull/42
+
+From 2eab7a8225b6fc0c6fd4773794abe83561f2d733 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Wed, 17 Apr 2024 00:48:11 +0100
+Subject: [PATCH] m4: fix quoting in readline.m4
+
+Without this, with autoconf-2.72 at least, we get:
+```
+$ ./configure
+[...]
+checking for pkg-config... /usr/sbin/pkg-config
+checking pkg-config is at least version 0.9.0... yes
+checking for tputs in -lcurses... ./configure: 5319: ac_fn_c_try_link: not found
+no
+checking for tputs in -lncurses... no
+[...]
+```
+--- a/m4/readline.m4
++++ b/m4/readline.m4
+@@ -9,24 +9,21 @@ AC_ARG_ENABLE(readline,
+ [use_readline=$enableval],
+ [use_readline=yes]) dnl Defaults to ON (if found)
+
+-if test "$use_readline" = "yes"; then
+- AC_CHECK_LIB(curses, tputs, LIBS="$LIBS -lcurses",
+- AC_CHECK_LIB(ncurses, tputs))
+- AC_CHECK_LIB(readline, readline)
++AS_IF([test "$use_readline" = "yes"], [
++ AC_CHECK_LIB([curses], [tputs], [LIBS="$LIBS -lcurses"],
++ [AC_CHECK_LIB([ncurses], [tputs])])
++ AC_CHECK_LIB([readline], [readline])
+
+- AC_SEARCH_LIBS(add_history, history,
+- AC_DEFINE(HAVE_ADD_HISTORY, 1, [Define if you have the add_history function])
++ AC_SEARCH_LIBS([add_history], [history],
++ AC_DEFINE([HAVE_ADD_HISTORY], [1], [Define if you have the add_history function])
+ )
+
+- AC_CHECK_HEADERS(history.h readline/history.h readline.h readline/readline.h)
++ AC_CHECK_HEADERS([history.h readline/history.h readline.h readline/readline.h])
+
+ # Check for rl_completion_matches as in readline 4.2
+- AC_CHECK_FUNCS(rl_completion_matches)
+-
++ AC_CHECK_FUNCS([rl_completion_matches])
++
+ msg_readline="enabled"
+-else
++], [
+ msg_readline="disabled"
+-fi
+-
+-])
+-
++])])
+--
+2.44.0
+
diff --git a/net-misc/cadaver/files/cadaver-0.24-link-cflags.patch b/net-misc/cadaver/files/cadaver-0.24-link-cflags.patch
new file mode 100644
index 000000000000..d2e18eefade4
--- /dev/null
+++ b/net-misc/cadaver/files/cadaver-0.24-link-cflags.patch
@@ -0,0 +1,26 @@
+https://github.com/notroj/cadaver/pull/42
+
+From e798c0144d3042cf6139d1ab85d84a8416cf5f00 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Wed, 17 Apr 2024 00:51:57 +0100
+Subject: [PATCH] Makefile.in: include CFLAGS at link-time
+
+GCC's documentation recommends this [0] for e.g. LTO. As a trivial silly
+example, my -fdiagnostics-color=always was stripped out, so a warning
+I got wasn't in colour.
+
+[0] https://gcc.gnu.org/onlinedocs/gcc/Optimize-Options.html#index-flto
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -56,7 +56,7 @@ all: $(TARGET)
+ .PHONY: subdirs install clean distclean
+
+ $(TARGET): $(ALLOBJS) subdirs
+- $(CC) $(LDFLAGS) -o $(TARGET) $(ALLOBJS) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(TARGET) $(ALLOBJS) $(LIBS)
+
+ .c.o:
+ $(CC) $(ALL_CFLAGS) -o $@ -c $<
+--
+2.44.0
+
diff --git a/net-misc/cadaver/files/cadaver-0.24-neon-0.33.patch b/net-misc/cadaver/files/cadaver-0.24-neon-0.33.patch
new file mode 100644
index 000000000000..9b6d1a2dceb7
--- /dev/null
+++ b/net-misc/cadaver/files/cadaver-0.24-neon-0.33.patch
@@ -0,0 +1,15 @@
+Trimmed from diffing upstream d0de5ee5276e83ac1b5ff6bde56084a565bff5fb
+to 3c8ecfe9bc8a7fbee58425be69aea89ae3f718e9, which included some
+extraneous bits.
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -35,7 +35,7 @@ AS_HELP_STRING([--disable-netrc],[enable .netrc support]),,
+
+ NEON_WITH_LIBS
+
+-NE_REQUIRE_VERSIONS([0], [27 28 29 30 31 32])
++NE_REQUIRE_VERSIONS([0], [27 28 29 30 31 32 33])
+
+ dnl Don't enable zlib or ACL support in neon
+ NEON_WITHOUT_ZLIB