summaryrefslogtreecommitdiff
path: root/net-misc/autoupnp/autoupnp-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/autoupnp/autoupnp-9999.ebuild')
-rw-r--r--net-misc/autoupnp/autoupnp-9999.ebuild28
1 files changed, 10 insertions, 18 deletions
diff --git a/net-misc/autoupnp/autoupnp-9999.ebuild b/net-misc/autoupnp/autoupnp-9999.ebuild
index c7de9275db3e..f7ea428391ea 100644
--- a/net-misc/autoupnp/autoupnp-9999.ebuild
+++ b/net-misc/autoupnp/autoupnp-9999.ebuild
@@ -1,35 +1,27 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-#if LIVE
-EGIT_REPO_URI="https://bitbucket.org/mgorny/${PN}.git"
+EAPI=7
inherit autotools git-r3
-#endif
-
-inherit eutils
DESCRIPTION="Automatic open port forwarder using UPnP"
-HOMEPAGE="https://bitbucket.org/mgorny/autoupnp/"
-SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+HOMEPAGE="https://github.com/mgorny/autoupnp/"
+EGIT_REPO_URI="https://github.com/mgorny/${PN}.git"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS=""
IUSE="libnotify"
RDEPEND="net-libs/miniupnpc:0=
libnotify? ( x11-libs/libtinynotify:0= )"
DEPEND="${RDEPEND}"
-#if LIVE
-KEYWORDS=
-SRC_URI=
-
-src_prepare() { eautoreconf; }
-#endif
+src_prepare() {
+ default
+ eautoreconf
+}
src_configure() {
local myconf=(
@@ -41,5 +33,5 @@ src_configure() {
src_install() {
default
- prune_libtool_files --all
+ find "${D}" -name '*.la' -delete || die
}