summaryrefslogtreecommitdiff
path: root/net-mail/vchkuser/vchkuser-0.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/vchkuser/vchkuser-0.4-r1.ebuild')
-rw-r--r--net-mail/vchkuser/vchkuser-0.4-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-mail/vchkuser/vchkuser-0.4-r1.ebuild b/net-mail/vchkuser/vchkuser-0.4-r1.ebuild
new file mode 100644
index 000000000000..d243ea098800
--- /dev/null
+++ b/net-mail/vchkuser/vchkuser-0.4-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools qmail
+
+DESCRIPTION="qmail-spp plugin to check recipient existance with vpopmail"
+HOMEPAGE="https://github.com/hollow/vchkuser"
+SRC_URI="https://github.com/hollow/vchkuser/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+DEPEND="
+ dev-libs/libpcre
+ net-mail/vpopmail
+ virtual/libcrypt:=
+ || (
+ mail-mta/netqmail[qmail-spp]
+ mail-mta/qmail-ldap[qmail-spp]
+ )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/hollow-${PN}-8a048f7"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ --with-vpopuser=vpopmail \
+ --with-qmailgroup=nofiles \
+ --with-vpopmaildir="${EPREFIX}"/var/vpopmail \
+ --with-qmaildir=${QMAIL_HOME}
+}
+
+src_install() {
+ default
+
+ fowners vpopmail:nofiles "${QMAIL_HOME}"/plugins/vchkuser
+ fperms 4750 "${QMAIL_HOME}"/plugins/vchkuser
+}