summaryrefslogtreecommitdiff
path: root/net-mail/rss2email/rss2email-3.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/rss2email/rss2email-3.11.ebuild')
-rw-r--r--net-mail/rss2email/rss2email-3.11.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-mail/rss2email/rss2email-3.11.ebuild b/net-mail/rss2email/rss2email-3.11.ebuild
new file mode 100644
index 000000000000..48bef2206afe
--- /dev/null
+++ b/net-mail/rss2email/rss2email-3.11.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Support for 3.7 needs support from dependencies, first
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python script that converts RSS/Atom newsfeeds to email"
+HOMEPAGE="https://github.com/rss2email/rss2email"
+SRC_URI="https://github.com/rss2email/rss2email/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND=">=dev-python/feedparser-5.0.1[${PYTHON_USEDEP}]
+ >=dev-python/html2text-3.01[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ distutils-r1_src_install
+ doman r2e.1
+}