summaryrefslogtreecommitdiff
path: root/net-mail/queue-repair
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/queue-repair')
-rw-r--r--net-mail/queue-repair/Manifest3
-rw-r--r--net-mail/queue-repair/metadata.xml1
-rw-r--r--net-mail/queue-repair/queue-repair-0.9.0-r2.ebuild35
3 files changed, 38 insertions, 1 deletions
diff --git a/net-mail/queue-repair/Manifest b/net-mail/queue-repair/Manifest
index 76424acbd577..354e8f47eb5c 100644
--- a/net-mail/queue-repair/Manifest
+++ b/net-mail/queue-repair/Manifest
@@ -1,3 +1,4 @@
DIST queue-repair-0.9.0.tar.gz 13913 BLAKE2B 04935bdb8473bad4d785732eabe2df7bd19d8e7b7364e1be516a8f94c6aee15c6f14bd171be8585f087ba0281281285f0695bb79a90a02519aa252a5884bfd7d SHA512 b7c21de207c80c3f764eddae6e60b4d54869f2037f572f98ff4e0a1e34f55ae1feeab5162b4f0f902a5a3c9d631c687057cdfdc4f646d6843d845f31f5b7bf6f
EBUILD queue-repair-0.9.0-r1.ebuild 712 BLAKE2B 869ab7d7dac0a90708da400c680d206fe619d1798b0e23841922d4d8bb17cba3f8af7552dcccfce09a8c5935663c8a0e25a0d52c926f75b2f40f2bb34698dafb SHA512 ea2eae4c33583966571da8647761f80e6457f5110e1c81f3ac04f31dd4bf093977a456e5ee616c962edc0f107360d645cfc40b0795dee285a56e15cb018d5aed
-MISC metadata.xml 466 BLAKE2B 521a85c974ed87b309ccbcd648599ffa3b20602a61654b164dd2b6b0f5cca7ac97716f211c9cef797604e842d6178c4c8345b2287dff3bac7a4c07072521b1ef SHA512 aa06f7e98e2c8e84edafa0a3662a7aa937389ede576f9fde6ae4ff5994faed83aee61b6f58d4a5b2db0d126a7a7f4b23fc7b4124eb4a5368511ebfa17856b17b
+EBUILD queue-repair-0.9.0-r2.ebuild 824 BLAKE2B 703bae7f00c410e2381d48f9435bc6b828513a75875a72ec666b8a597f1111c423ad965a37a6438a05c9a27aa6442fc564b24aebe05edbb0d189d179391093fd SHA512 e72593fb8b5eb51e7645f0e36e09544e2b8739c27cf53acdb5ebe04d858e9dcd05be990f7c243d10ac4d331a54e536be5c8c0733ae2c84e46568932cfefe9ecd
+MISC metadata.xml 490 BLAKE2B 8ec4d8e23a4956f5679a0b5291b03262a4474f3d0d97a5fc3286189f5623c75d859ce8103708dfe3ed1e4e3721165a764b121364f06121289aff047cd60db281 SHA512 bf57215deceddaa74691029e05f52940c0bd1d9262c865980c35786f487d08351e24287c50685ef85514a1e7cc7cb68d527259b369a34d6d06bf8fd4474285b1
diff --git a/net-mail/queue-repair/metadata.xml b/net-mail/queue-repair/metadata.xml
index 148b1e2765b0..f966cd555df5 100644
--- a/net-mail/queue-repair/metadata.xml
+++ b/net-mail/queue-repair/metadata.xml
@@ -8,4 +8,5 @@
value, convert big-todo queues to non-big-todo and vice versa, and repair a
corrupted queue.
</longdescription>
+ <stabilize-allarches/>
</pkgmetadata>
diff --git a/net-mail/queue-repair/queue-repair-0.9.0-r2.ebuild b/net-mail/queue-repair/queue-repair-0.9.0-r2.ebuild
new file mode 100644
index 000000000000..a67868c14c27
--- /dev/null
+++ b/net-mail/queue-repair/queue-repair-0.9.0-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-single-r1
+
+DESCRIPTION="A toolkit for dealing with the qmail queue directory structure"
+HOMEPAGE="http://pyropus.ca/software/queue-repair/"
+SRC_URI="http://pyropus.ca/software/queue-repair/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="test" # no tests
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+DOCS=( BLURB TODO CHANGELOG )
+
+src_prepare() {
+ eapply_user
+
+ 2to3 -n -w --no-diffs queue_repair.py || die
+}
+
+src_install() {
+ python_newscript queue_repair.py queue-repair.py
+ dosym queue-repair.py /usr/bin/queue-repair
+ einstalldocs
+}