summaryrefslogtreecommitdiff
path: root/net-mail/qmailadmin/qmailadmin-1.2.15-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/qmailadmin/qmailadmin-1.2.15-r1.ebuild')
-rw-r--r--net-mail/qmailadmin/qmailadmin-1.2.15-r1.ebuild43
1 files changed, 20 insertions, 23 deletions
diff --git a/net-mail/qmailadmin/qmailadmin-1.2.15-r1.ebuild b/net-mail/qmailadmin/qmailadmin-1.2.15-r1.ebuild
index ddd66ac34bfb..3e99cdd3a1a7 100644
--- a/net-mail/qmailadmin/qmailadmin-1.2.15-r1.ebuild
+++ b/net-mail/qmailadmin/qmailadmin-1.2.15-r1.ebuild
@@ -1,13 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit qmail eutils webapp autotools
-
-# the RESTRICT is because the vpopmail lib directory is locked down
-# and non-root can't access them.
-RESTRICT="userpriv"
+inherit qmail webapp autotools
MY_P=${P/_rc/-rc}
@@ -20,24 +16,27 @@ SLOT="0"
WEBAPP_MANUAL_SLOT="yes"
KEYWORDS="amd64 arm ~hppa ia64 ppc s390 sh sparc x86"
IUSE="maildrop"
+# the RESTRICT is because the vpopmail lib directory is locked down
+# and non-root can't access them.
+RESTRICT="userpriv"
-DEPEND="virtual/qmail
+RDEPEND="virtual/qmail
>=net-mail/vpopmail-5.4.33
net-mail/autorespond
maildrop? ( >=mail-filter/maildrop-2.0.1 )"
+DEPEND=${RDEPEND}
S="${WORKDIR}"/${MY_P}
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.2.9-maildir.patch
- epatch "${FILESDIR}"/${PN}-1.2.12-quota-overflow.patch
- epatch "${FILESDIR}"/${PN}-1.2.15-quota-security.patch
+src_prepare() {
+ eapply "${FILESDIR}"/${PN}-1.2.9-maildir.patch
+ eapply "${FILESDIR}"/${PN}-1.2.12-quota-overflow.patch
+ eapply "${FILESDIR}"/${PN}-1.2.15-quota-security.patch
+ eapply_user
eautoreconf
}
-src_compile() {
+src_configure() {
# Pass spam stuff through $@ so we get the quoting right
if use maildrop ; then
set -- --enable-modify-spam \
@@ -68,19 +67,17 @@ src_compile() {
--enable-maxaliasesperpage=50 \
--enable-vpopuser=vpopmail \
--enable-vpopgroup=vpopmail \
- "$@" \
- || die "econf failed"
-
- emake || die "make failed"
+ "$@"
}
src_install() {
webapp_src_preinst
- make DESTDIR="${D}" install || die "make install failed"
-
- dodoc AUTHORS INSTALL README.hooks BUGS TODO ChangeLog \
- TRANSLATORS NEWS FAQ README contrib/*
+ local DOCS=(
+ AUTHORS INSTALL README.hooks BUGS TODO ChangeLog TRANSLATORS
+ NEWS FAQ README contrib/*
+ )
+ default
webapp_src_install
}