summaryrefslogtreecommitdiff
path: root/net-mail/qmail-notify/qmail-notify-0.93-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/qmail-notify/qmail-notify-0.93-r2.ebuild')
-rw-r--r--net-mail/qmail-notify/qmail-notify-0.93-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-mail/qmail-notify/qmail-notify-0.93-r2.ebuild b/net-mail/qmail-notify/qmail-notify-0.93-r2.ebuild
new file mode 100644
index 000000000000..98b35abcccd0
--- /dev/null
+++ b/net-mail/qmail-notify/qmail-notify-0.93-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Delayed delivery notification for qmail"
+SRC_URI="http://untroubled.org/qmail-notify/archive/${P}.tar.gz"
+HOMEPAGE="http://untroubled.org/qmail-notify/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ virtual/cron
+ virtual/qmail
+"
+
+src_prepare() {
+ eapply_user
+
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc || die 'Patching conf-cc failed.'
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld || die 'Patching conf-ld failed.'
+ sed -e "#'ar #'$(tc-getAR) #" -e "s#'ranlib #'$(tc-getRANLIB) #" -i Makefile || die 'Patching Makefile failed.'
+}
+
+src_install () {
+ exeinto /usr/sbin
+ doexe qmail-notify
+
+ exeinto /etc/cron.hourly
+ doexe "${FILESDIR}"/qmail-notify.cron
+
+ dodoc README ANNOUNCEMENT cron.hourly NEWS
+}
+
+pkg_postinst() {
+ elog
+ elog "Edit qmail-notify.cron in /etc/cron.hourly"
+ elog "to activate qmail-notify!"
+ elog
+}