summaryrefslogtreecommitdiff
path: root/net-mail/postfix-logwatch/postfix-logwatch-1.40.04.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/postfix-logwatch/postfix-logwatch-1.40.04.ebuild')
-rw-r--r--net-mail/postfix-logwatch/postfix-logwatch-1.40.04.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-mail/postfix-logwatch/postfix-logwatch-1.40.04.ebuild b/net-mail/postfix-logwatch/postfix-logwatch-1.40.04.ebuild
new file mode 100644
index 000000000000..bab89768c04c
--- /dev/null
+++ b/net-mail/postfix-logwatch/postfix-logwatch-1.40.04.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A log analyzer for postfix"
+HOMEPAGE="http://michael.orlitzky.com/code/postfix-logwatch.xhtml"
+SRC_URI="http://michael.orlitzky.com/code/releases/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/perl"
+
+src_prepare() {
+ default
+ # Replace the default config file location with ours.
+ local cfg_default='/usr/local/etc/${progname_prefix}-logwatch.conf'
+ local cfg_gentoo='/etc/${progname_prefix}-logwatch.conf';
+ sed -i "s~${cfg_default}~${cfg_gentoo}~" ${PN} \
+ || die 'failed to update the default config location'
+}
+
+src_install() {
+ dodoc Bugs Changes README ${PN}.conf-topn
+ doman ${PN}.1
+ dobin ${PN}
+ insinto /etc
+ doins ${PN}.conf
+}