summaryrefslogtreecommitdiff
path: root/net-mail/mswatch/mswatch-1.2.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/mswatch/mswatch-1.2.0-r1.ebuild')
-rw-r--r--net-mail/mswatch/mswatch-1.2.0-r1.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/net-mail/mswatch/mswatch-1.2.0-r1.ebuild b/net-mail/mswatch/mswatch-1.2.0-r1.ebuild
index 06d3a3d17125..7c542663566e 100644
--- a/net-mail/mswatch/mswatch-1.2.0-r1.ebuild
+++ b/net-mail/mswatch/mswatch-1.2.0-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit linux-info ltprune
+EAPI=7
+
+inherit linux-info
DESCRIPTION="A utility to watch mailstores for changes and initiate mailbox syncs"
HOMEPAGE="http://mswatch.sourceforge.net/"
@@ -11,12 +12,10 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="static-libs"
+BDEPEND="virtual/pkgconfig"
RDEPEND=">=dev-libs/glib-2.6:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
+DEPEND="${RDEPEND}"
CONFIG_CHECK="~INOTIFY_USER"
ERROR_INOTIFY_USER="${P} requires in-kernel inotify support."
@@ -30,10 +29,11 @@ src_configure() {
econf \
--with-notify=inotify \
--enable-shared \
- $(use_enable static-libs static)
+ --disable-static
}
src_install() {
default
- prune_libtool_files
+
+ find "${ED}" -name '*.la' -delete || die
}