summaryrefslogtreecommitdiff
path: root/net-mail/mailbase/mailbase-1.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/mailbase/mailbase-1.5-r1.ebuild')
-rw-r--r--net-mail/mailbase/mailbase-1.5-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-mail/mailbase/mailbase-1.5-r1.ebuild b/net-mail/mailbase/mailbase-1.5-r1.ebuild
new file mode 100644
index 000000000000..8a212cf0d798
--- /dev/null
+++ b/net-mail/mailbase/mailbase-1.5-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit pam
+
+DESCRIPTION="MTA layout package"
+SRC_URI=""
+HOMEPAGE="https://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="pam"
+
+RDEPEND="
+ acct-group/mail
+ acct-user/mail
+ acct-user/postmaster
+ pam? ( virtual/pam )"
+
+S=${WORKDIR}
+
+src_install() {
+ dodir /etc/mail
+ insinto /etc/mail
+ doins "${FILESDIR}"/aliases
+ insinto /etc
+ doins "${FILESDIR}"/mailcap
+ doman "${FILESDIR}"/mailcap.5
+
+ dosym spool/mail /var/mail
+
+ newpamd "${FILESDIR}"/common-pamd-include pop
+ newpamd "${FILESDIR}"/common-pamd-include imap
+ if use pam ; then
+ local p
+ for p in pop3 pop3s pops ; do
+ dosym pop /etc/pam.d/${p}
+ done
+ for p in imap4 imap4s imaps ; do
+ dosym imap /etc/pam.d/${p}
+ done
+ fi
+}