summaryrefslogtreecommitdiff
path: root/net-mail/kuvert
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/kuvert')
-rw-r--r--net-mail/kuvert/Manifest3
-rw-r--r--net-mail/kuvert/kuvert-2.0.4.ebuild43
-rw-r--r--net-mail/kuvert/metadata.xml5
3 files changed, 51 insertions, 0 deletions
diff --git a/net-mail/kuvert/Manifest b/net-mail/kuvert/Manifest
new file mode 100644
index 000000000000..0ca37124ee00
--- /dev/null
+++ b/net-mail/kuvert/Manifest
@@ -0,0 +1,3 @@
+DIST kuvert_2.0.4.tar.gz 118352 BLAKE2B 424968de1fc915c3858acb9c86fc9e90578db676502d0beae0d4c36217a53427884b79c24ffe2ef4f9e80b07a07a8aebf02a1b57271e6fb0b251210f4e439323 SHA512 01421ca8cf86de935040ecb7312833190e97bd99d3d3ab32356b1249df4e11eefa02cd9f0784d2c6c9135d065ee184b508efa55e5865d0b586f3267956611f1f
+EBUILD kuvert-2.0.4.ebuild 844 BLAKE2B 6d814a30b201d2cc227aae2913af43a114543f64475d49d85585bff589172a693bf0c1b3830b59cf101b28c0451c63e82401a2dcb736e47b72471520c325cc2d SHA512 80c5bc623b10af52c2c8363a62dd54528cc750681e4353a315c60aea25a466f0f2bbc271f0488c14ae9d6483691f5c798db0a27ab967c6721aa76e23495f9d66
+MISC metadata.xml 168 BLAKE2B 5f277cc66dbafa7e7985433f84b0f9a656a176a9b901862e2a8353ca2d4526797dded9696e835b9696c7f72324e94959cfb5a22de49a7e3e61604153886037ab SHA512 00eec08786156434460f5ed77b647579546cf1a86341a4f2c9c9c84326468c2c21dc5101c4277103b19266bb6f788823f4ddf3b9d044da26326d79bf2ac9a274
diff --git a/net-mail/kuvert/kuvert-2.0.4.ebuild b/net-mail/kuvert/kuvert-2.0.4.ebuild
new file mode 100644
index 000000000000..18570068f804
--- /dev/null
+++ b/net-mail/kuvert/kuvert-2.0.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit toolchain-funcs
+
+MY_P=${P/-/_}
+
+DESCRIPTION="An MTA wrapper that automatically signs and/or encrypts
+outgoing mail"
+HOMEPAGE="http://www.snafu.priv.at/mystuff/kuvert/"
+SRC_URI="http://www.snafu.priv.at/mystuff/kuvert/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 ~ppc"
+IUSE=""
+SLOT="0"
+
+S="${WORKDIR}/${PN}"
+
+DEPEND=""
+RDEPEND="app-crypt/gnupg
+ sys-apps/keyutils
+ dev-perl/MailTools
+ dev-perl/MIME-tools
+ dev-perl/Authen-SASL
+ dev-perl/File-Slurp
+ dev-perl/Net-Server-Mail
+ virtual/perl-IO
+ virtual/perl-File-Temp
+ virtual/perl-Time-HiRes
+ dev-lang/perl
+ virtual/perl-libnet
+ virtual/mta"
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc dot-kuvert README THANKS TODO
+}
diff --git a/net-mail/kuvert/metadata.xml b/net-mail/kuvert/metadata.xml
new file mode 100644
index 000000000000..1b2becffa26c
--- /dev/null
+++ b/net-mail/kuvert/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+</pkgmetadata>