summaryrefslogtreecommitdiff
path: root/net-mail/gnubiff/gnubiff-2.2.15-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/gnubiff/gnubiff-2.2.15-r3.ebuild')
-rw-r--r--net-mail/gnubiff/gnubiff-2.2.15-r3.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-mail/gnubiff/gnubiff-2.2.15-r3.ebuild b/net-mail/gnubiff/gnubiff-2.2.15-r3.ebuild
new file mode 100644
index 000000000000..b22d67e1a6cb
--- /dev/null
+++ b/net-mail/gnubiff/gnubiff-2.2.15-r3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="A mail notification program"
+HOMEPAGE="http://gnubiff.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug fam nls password"
+
+RDEPEND="
+ >=x11-libs/gtk+-3:3
+ >=gnome-base/libglade-2.3
+ dev-libs/popt
+ password? ( dev-libs/openssl:0= )
+ fam? ( virtual/fam )
+ x11-libs/libX11
+ x11-libs/pango
+ x11-libs/gdk-pixbuf
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+DOCS="AUTHORS ChangeLog NEWS README THANKS TODO"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-fix-nls.patch \
+ "${FILESDIR}"/${P}-gold.patch \
+ "${FILESDIR}"/${P}-underlink.patch
+ eautoreconf
+}
+
+src_configure() {
+ # note: --disable-gnome is to avoid deprecated gnome-panel-2.x
+ econf \
+ --disable-gnome \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable fam) \
+ $(use_with password) \
+ $(use_with password password-string ${RANDOM}${RANDOM}${RANDOM}${RANDOM})
+}