summaryrefslogtreecommitdiff
path: root/net-mail/getmail/getmail-6.18.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/getmail/getmail-6.18.9.ebuild')
-rw-r--r--net-mail/getmail/getmail-6.18.9.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-mail/getmail/getmail-6.18.9.ebuild b/net-mail/getmail/getmail-6.18.9.ebuild
new file mode 100644
index 000000000000..734f390f84cf
--- /dev/null
+++ b/net-mail/getmail/getmail-6.18.9.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="ssl"
+inherit distutils-r1
+
+DESCRIPTION="A mail retriever with reliable Maildir and mbox delivery"
+HOMEPAGE="https://www.getmail6.org/ https://github.com/getmail6/getmail6"
+SRC_URI="https://github.com/getmail6/getmail6/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/getmail6-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+
+python_prepare_all() {
+ # Use gentoo version number (including revision) for doc dir and remove COPYING file
+ sed -i -e "s,'getmail-%s' % __version__,'${PF}'," \
+ -e "/docs\/COPYING/d" "${S}"/setup.py || die
+
+ distutils-r1_python_prepare_all
+}