summaryrefslogtreecommitdiff
path: root/net-mail/getmail/getmail-5.14.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/getmail/getmail-5.14.ebuild')
-rw-r--r--net-mail/getmail/getmail-5.14.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-mail/getmail/getmail-5.14.ebuild b/net-mail/getmail/getmail-5.14.ebuild
new file mode 100644
index 000000000000..813ca4429c80
--- /dev/null
+++ b/net-mail/getmail/getmail-5.14.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="ssl?"
+
+inherit distutils-r1
+
+DESCRIPTION="A mail retriever with reliable Maildir and mbox delivery"
+HOMEPAGE="http://pyropus.ca/software/getmail/"
+SRC_URI="http://pyropus.ca/software/getmail/old-versions/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc-macos ~x86-macos ~x64-solaris"
+IUSE="ssl"
+
+python_prepare_all() {
+ sed -i -e "s,'getmail-%s' % __version__,'${PF}'," \
+ -e "/docs\/COPYING/d" "${S}"/setup.py || die
+
+ distutils-r1_python_prepare_all
+}