summaryrefslogtreecommitdiff
path: root/net-libs
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/Manifest.gzbin33970 -> 33982 bytes
-rw-r--r--net-libs/ignition-transport/Manifest4
-rw-r--r--net-libs/ignition-transport/ignition-transport-3.1.0.ebuild36
-rw-r--r--net-libs/ldns/Manifest2
-rw-r--r--net-libs/ldns/ldns-1.7.0-r1.ebuild2
-rw-r--r--net-libs/nodejs/Manifest1
-rw-r--r--net-libs/nodejs/nodejs-99999999.ebuild200
7 files changed, 242 insertions, 3 deletions
diff --git a/net-libs/Manifest.gz b/net-libs/Manifest.gz
index 639cf62b4adc..8c76a37962c6 100644
--- a/net-libs/Manifest.gz
+++ b/net-libs/Manifest.gz
Binary files differ
diff --git a/net-libs/ignition-transport/Manifest b/net-libs/ignition-transport/Manifest
index 321276515bb3..1dc3bbe39cb7 100644
--- a/net-libs/ignition-transport/Manifest
+++ b/net-libs/ignition-transport/Manifest
@@ -1,3 +1,5 @@
-DIST ignition-transport3-3.0.1.tar.bz2 384679 SHA256 c2b8dd5f391a30f1239893b51d4ea487fd47bfe12ccdb3876a83df192df666be SHA512 a2e80d3b5a8b0ca327bd8892d1177f8316d3e2dbbb6f064626e00eb5e67572519377290973527d69ab4a8ff3970c350a7066625429d3a8403a5be8d491fb89c6 WHIRLPOOL 986b4af3deb1d24c3a4f9ff89b3e526efbf68f278b9ed0fff513fbf095e2f1752a4552a8c652545619fa3f5223f0353b68c728af0623f0ec66a2f6bc5aee01a5
+DIST ignition-transport3-3.0.1.tar.bz2 384679 BLAKE2B 1aace81c8d708dc06dedb53453718b019b1472c6c787fddb3b76c9e97cf2d518db2e037c20451b10c31db8a31d87b70f93c8339515a98f376bb660798bf07cd8 SHA512 a2e80d3b5a8b0ca327bd8892d1177f8316d3e2dbbb6f064626e00eb5e67572519377290973527d69ab4a8ff3970c350a7066625429d3a8403a5be8d491fb89c6
+DIST ignition-transport3-3.1.0.tar.bz2 385946 BLAKE2B 0ae44f0e1cd17369de9ee39f0d128ee5edbc68c1be672be5476d7cf8c161f59c069af63cec1966f6e0ba1c9e56ade0563b6546f7f285bdc49b6941939e2a4379 SHA512 438ab49f1c506e098c00becccf1856b3e0129d60f9aca32f713a74b38aefb178833353ff479c8512e7ffec812bdc0a06eb7f28f09766dc0cc5a9707184151555
EBUILD ignition-transport-3.0.1.ebuild 1049 BLAKE2B 4dadc025a21222df813cddadc068aaed5d83c81c405842096ad4fc2cc37185eb2206557c61864590683346a755fbbce5ce0b1d851540c7b23bf25deee19eea82 SHA512 0f327196dcff9067c14c14b8287bff381654f6ec84687bd3bf2c953c0b5e006eb0f535655c9d35d358a83b0373a012fc0cde14e994c1d68e89ac4a3f943c84ca
+EBUILD ignition-transport-3.1.0.ebuild 1049 BLAKE2B 4dadc025a21222df813cddadc068aaed5d83c81c405842096ad4fc2cc37185eb2206557c61864590683346a755fbbce5ce0b1d851540c7b23bf25deee19eea82 SHA512 0f327196dcff9067c14c14b8287bff381654f6ec84687bd3bf2c953c0b5e006eb0f535655c9d35d358a83b0373a012fc0cde14e994c1d68e89ac4a3f943c84ca
MISC metadata.xml 243 BLAKE2B 13c40383778472fec33f877963b2be8d44c354e5449e3ac38dfba06cb38e4cfb6a63d5d73c5acb1e02a1c8ee783131c46c8b56eb14de786de7f77635f15d18d7 SHA512 c9d5c1cdd2874fe293f21f7584c6e15ef9439bd82b0d2e862e3e34c9a9e0e3191370fee2727b9d4d8647fb85cf56a39fdd6c1e0003ada1554496aad311ef335c
diff --git a/net-libs/ignition-transport/ignition-transport-3.1.0.ebuild b/net-libs/ignition-transport/ignition-transport-3.1.0.ebuild
new file mode 100644
index 000000000000..8c6b71bda1c3
--- /dev/null
+++ b/net-libs/ignition-transport/ignition-transport-3.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-utils vcs-snapshot flag-o-matic
+
+DESCRIPTION="Combines ZeroMQ with Protobufs to create a fast and efficient message passing system"
+HOMEPAGE="http://ignitionrobotics.org/libraries/transport"
+SRC_URI="http://gazebosim.org/distributions/ign-transport/releases/${PN}3-${PV}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="3/3"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ net-libs/ignition-msgs:=
+ dev-libs/protobuf:=
+ >=net-libs/zeromq-3.2.0:=
+ sys-apps/util-linux
+ net-libs/cppzmq
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+CMAKE_BUILD_TYPE=RelWithDebInfo
+S="${WORKDIR}/${PN}3-${PV}"
+
+src_configure() {
+ # upstream appends this conditionally...
+ append-flags "-fPIC"
+ echo "set (CMAKE_C_FLAGS_ALL \"${CXXFLAGS} \${CMAKE_C_FLAGS_ALL}\")" > "${S}/cmake/HostCFlags.cmake"
+ sed -i -e "s/LINK_FLAGS_RELWITHDEBINFO \" \"/LINK_FLAGS_RELWITHDEBINFO \" ${LDFLAGS} \"/" cmake/DefaultCFlags.cmake || die
+ cmake-utils_src_configure
+}
diff --git a/net-libs/ldns/Manifest b/net-libs/ldns/Manifest
index f88f72b84735..4f6a209b46f2 100644
--- a/net-libs/ldns/Manifest
+++ b/net-libs/ldns/Manifest
@@ -5,5 +5,5 @@ DIST ldns-1.6.17.tar.gz 1315403 BLAKE2B 67cf163c0fc529730f6de6a7ed3c581a2fdc3be7
DIST ldns-1.7.0.tar.gz 1304424 BLAKE2B 2f37aa2d00c1d9cf18711bd4f873f4722df01c4f4d0f627e054f04b2473c0fbf19449e293a130d5c8b98dcebafeb3d7b3f5923ae0244bd80139cea77f2171e06 SHA512 8a4e48bcc2a244b92447a9830b60efbb656fb7955f3559ef2eb6f8e724c4c0208776350c44ccf7dcf1ffe0b7b9d9ccc4cbddc5bc16e8888db494ab4d0bce3bd8
EBUILD ldns-1.6.17-r1.ebuild 2502 BLAKE2B b1b54f8308b887e0f3e06d0bdc993cc29e7dc89a660dab105b943cc125025f545796917b940861c11afd311e5c2351be8d941689c2fb2e0b2a80b684cb7ab85a SHA512 30aa360319dd0e9e3a4095fa988ed940a899af72b448b2d4d33fa18f57eee3557eaa20fcc4988deb7821d7ec6a12de88a9f687edb7b964883ffd51e58d14ae83
EBUILD ldns-1.6.17.ebuild 2196 BLAKE2B 5edd80744d5bed7892bb56a5a80305e04780cebd8ef064f3c2f63494eb46eaba4a7580ec285cce6d32e273b3b162024a0388503364abdca6ac0dc7f9e20e6df6 SHA512 70b0785d6380ae4ce03702a5ce396b00275e7dd1548abc96a49444a23e9e370aabc7585d5683fabfca6f512f70ce5acdb7e793d72417a451582920d1f9a7fad5
-EBUILD ldns-1.7.0-r1.ebuild 2625 BLAKE2B 72124448b9826350d2dab7cae1ca4640ffa16c0c0588cb4f376d35b5f469c227e1ab1af35675eab7e7eba1ef9d0027a2700f2b71a6c07a9d26ac6fbdd31b16e2 SHA512 99a6f6821fa2955015eeeb0b96320d1d3d0d01bab766eabe0152026edbcb73a5eda08af30b6c6c28a4fc7867a65bfaafc02fb928863ef24f4c09ada86004d14f
+EBUILD ldns-1.7.0-r1.ebuild 2624 BLAKE2B c233f6cf60eca93fcc04ae3de39b81ff1bdc8a52bb35cf321bd1fc9642a90558f47674785e96423a7e59a4902b73a3f2d2e07bb44f48019a1cd9e13d9706b7f5 SHA512 95975451656e977f6db9098b142812a8d6ff36da1bd1adad2ca3f7cd712fdacec9f461dfe3b4663cb1ab7882076398364ab4fecd3771ba8ca9c50f9bd4335c7e
MISC metadata.xml 743 BLAKE2B 31fe371130dca55cc2950a0892ddf2e97f1c7260b57e893932c14d2af254b1c9272a678a4365762247b5fd7a6e2e6c1a58dd326f3837e0e12389bb08f493562a SHA512 b8d5c5fd107fb7dd7dc2d7d19fbb91a07a2a619b6c9ddd9146d9359c06ed96059c87d169b7c2022760e4117283372c01b6f5231edf975bbab9c72a3ee8347f35
diff --git a/net-libs/ldns/ldns-1.7.0-r1.ebuild b/net-libs/ldns/ldns-1.7.0-r1.ebuild
index 37990754fa8a..677dd61c4b13 100644
--- a/net-libs/ldns/ldns-1.7.0-r1.ebuild
+++ b/net-libs/ldns/ldns-1.7.0-r1.ebuild
@@ -12,7 +12,7 @@ SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~ppc-macos ~x64-macos ~x64-solaris"
+KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~amd64-fbsd ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="+dane doc +ecdsa gost libressl python +ssl static-libs vim-syntax"
# configure will die if ecdsa is enabled and ssl is not
diff --git a/net-libs/nodejs/Manifest b/net-libs/nodejs/Manifest
index dfbc329b4d5f..5e4fa48d1090 100644
--- a/net-libs/nodejs/Manifest
+++ b/net-libs/nodejs/Manifest
@@ -15,4 +15,5 @@ EBUILD nodejs-6.9.4.ebuild 6073 BLAKE2B cf41081773527f8efb120d6d7ba8d21dc834fc47
EBUILD nodejs-8.9.1-r1.ebuild 6421 BLAKE2B 1cc15687b44dc144b6f004483ed7fb875a3ebc3b2d82c6fdc95cd62b2c2e2ba2400dbb95c5a7ffa9cb338d6bab09fb4ef098fa71e3b3c2d32f6ddd302f384a6e SHA512 8c312851a25fd71aa64fc9b3a209f463b1c5099d87a0ae5ad3b6ba6c4c41651a683249c09b81079cc990c8bdb38bcca12138eec7f4a3d03d04a75c9036c60d7d
EBUILD nodejs-8.9.2.ebuild 6421 BLAKE2B 1cc15687b44dc144b6f004483ed7fb875a3ebc3b2d82c6fdc95cd62b2c2e2ba2400dbb95c5a7ffa9cb338d6bab09fb4ef098fa71e3b3c2d32f6ddd302f384a6e SHA512 8c312851a25fd71aa64fc9b3a209f463b1c5099d87a0ae5ad3b6ba6c4c41651a683249c09b81079cc990c8bdb38bcca12138eec7f4a3d03d04a75c9036c60d7d
EBUILD nodejs-9.2.0-r1.ebuild 6421 BLAKE2B 8373da68cf051d055edfe47e737ecd091dce243430efb25cd9ce2b04213a16364aac0613ff793ef7e44dde94a1c28bfa7b0711c7bfa02a80c01097fb6dfcb546 SHA512 25d09d0fed3bf63d67edfc98699388b8fdd33812577417704f2a242f9e8290dce509c6c90b335020960a387999e35c0343256e5a85003b9a253bcd14ba805eb1
+EBUILD nodejs-99999999.ebuild 6279 BLAKE2B 4fdab839abcf93e72846133d67e1bddbc3f6df9030f3c50136d21b1a563abffa03042f20264522d4fb6326f4cd7496790e50f027e9b9799d8c557dbb19acea9b SHA512 790483bcd7ca2f1cd362760a9b19bf0d09ec7359ea583909e64bba556b3ed3da13767e611bb64f91c2002650086c2247a1a52088ba62e271d2bb149f5b52fb13
MISC metadata.xml 502 BLAKE2B 8640b71810454f7c091026e02910563ee44866ed666fc18be431415054ce38e6dab45f8e1890161d5b39e6eafe0279caed936046b803e619880a7ddeb3e4e428 SHA512 bc6fd0a671ad96d8c3f190514932ccc19319c895829136cd04d99b4123666380ed84502d7dea711dfb1d0ba7f0c6edb88afdc95ff24fbca4a6ad636062b5c32a
diff --git a/net-libs/nodejs/nodejs-99999999.ebuild b/net-libs/nodejs/nodejs-99999999.ebuild
new file mode 100644
index 000000000000..846c80299fc9
--- /dev/null
+++ b/net-libs/nodejs/nodejs-99999999.ebuild
@@ -0,0 +1,200 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="test"
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads"
+
+inherit bash-completion-r1 eutils flag-o-matic git-r3 pax-utils python-single-r1 toolchain-funcs
+
+DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
+HOMEPAGE="https://nodejs.org/"
+EGIT_REPO_URI="https://github.com/nodejs/node"
+
+LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="cpu_flags_x86_sse2 debug doc icu inspector +npm +snapshot +ssl systemtap test"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ inspector? ( icu ssl )
+"
+
+RDEPEND="
+ >=dev-libs/libuv-1.16.1:=
+ >=net-libs/http-parser-2.7.0:=
+ >=net-libs/nghttp2-1.25.0
+ sys-libs/zlib
+ icu? ( >=dev-libs/icu-59:= )
+ npm? ( ${PYTHON_DEPS} )
+ ssl? ( >=dev-libs/openssl-1.0.2g:0=[-bindist] )
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ systemtap? ( dev-util/systemtap )
+ test? ( net-misc/curl )"
+
+PATCHES=(
+ "${FILESDIR}"/gentoo-global-npm-config.patch
+)
+
+pkg_pretend() {
+ (use x86 && ! use cpu_flags_x86_sse2) && \
+ die "Your CPU doesn't support the required SSE2 instruction."
+
+ ( [[ ${MERGE_TYPE} != "binary" ]] && ! test-flag-CXX -std=c++11 ) && \
+ die "Your compiler doesn't support C++11. Use GCC 4.8, Clang 3.3 or newer."
+}
+
+src_prepare() {
+ tc-export CC CXX PKG_CONFIG
+ export V=1
+ export BUILDTYPE=Release
+
+ # fix compilation on Darwin
+ # https://code.google.com/p/gyp/issues/detail?id=260
+ sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
+
+ # make sure we use python2.* while using gyp
+ sed -i -e "s/python/${EPYTHON}/" deps/npm/node_modules/node-gyp/gyp/gyp || die
+ sed -i -e "s/|| 'python2'/|| '${EPYTHON}'/" deps/npm/node_modules/node-gyp/lib/configure.js || die
+
+ # less verbose install output (stating the same as portage, basically)
+ sed -i -e "/print/d" tools/install.py || die
+
+ # proper libdir, hat tip @ryanpcmcquen https://github.com/iojs/io.js/issues/504
+ local LIBDIR=$(get_libdir)
+ sed -i -e "s|lib/|${LIBDIR}/|g" tools/install.py || die
+ sed -i -e "s/'lib'/'${LIBDIR}'/" lib/module.js deps/npm/lib/npm.js || die
+
+ # Avoid writing a depfile, not useful
+ sed -i -e "/DEPFLAGS =/d" tools/gyp/pylib/gyp/generator/make.py || die
+
+ sed -i -e "/'-O3'/d" common.gypi deps/v8/gypfiles/toolchain.gypi || die
+
+ # Avoid a test that I've only been able to reproduce from emerge. It doesnt
+ # seem sandbox related either (invoking it from a sandbox works fine).
+ # The issue is that no stdin handle is openened when asked for one.
+ # It doesn't really belong upstream , so it'll just be removed until someone
+ # with more gentoo-knowledge than me (jbergstroem) figures it out.
+ rm test/parallel/test-stdout-close-unref.js || die
+
+ # debug builds. change install path, remove optimisations and override buildtype
+ if use debug; then
+ sed -i -e "s|out/Release/|out/Debug/|g" tools/install.py || die
+ BUILDTYPE=Debug
+ fi
+
+ default
+}
+
+src_configure() {
+ local myconf=( --shared-http-parser --shared-libuv --shared-nghttp2 --shared-zlib )
+ use debug && myconf+=( --debug )
+ use icu && myconf+=( --with-intl=system-icu ) || myconf+=( --with-intl=none )
+ use inspector || myconf+=( --without-inspector )
+ use npm || myconf+=( --without-npm )
+ use snapshot && myconf+=( --with-snapshot )
+ use ssl && myconf+=( --shared-openssl ) || myconf+=( --without-ssl )
+
+ local myarch=""
+ case ${ABI} in
+ amd64) myarch="x64";;
+ arm) myarch="arm";;
+ arm64) myarch="arm64";;
+ ppc64) myarch="ppc64";;
+ x32) myarch="x32";;
+ x86) myarch="ia32";;
+ *) myarch="${ABI}";;
+ esac
+
+ GYP_DEFINES="linux_use_gold_flags=0
+ linux_use_bundled_binutils=0
+ linux_use_bundled_gold=0" \
+ "${PYTHON}" configure \
+ --prefix="${EPREFIX}"/usr \
+ --dest-cpu=${myarch} \
+ $(use_with systemtap dtrace) \
+ "${myconf[@]}" || die
+}
+
+src_compile() {
+ emake -C out mksnapshot
+ pax-mark m "out/${BUILDTYPE}/mksnapshot"
+ emake -C out
+}
+
+src_install() {
+ local LIBDIR="${ED}/usr/$(get_libdir)"
+ emake install DESTDIR="${D}"
+ pax-mark -m "${ED}"usr/bin/node
+
+ # set up a symlink structure that node-gyp expects..
+ dodir /usr/include/node/deps/{v8,uv}
+ dosym . /usr/include/node/src
+ for var in deps/{uv,v8}/include; do
+ dosym ../.. /usr/include/node/${var}
+ done
+
+ if use doc; then
+ # Patch docs to make them offline readable
+ for i in `grep -rl 'fonts.googleapis.com' "${S}"/out/doc/api/*`; do
+ sed -i '/fonts.googleapis.com/ d' $i;
+ done
+ # Install docs!
+ dohtml -r "${S}"/doc/*
+ fi
+
+ if use npm; then
+ dodir /etc/npm
+
+ # Install bash completion for `npm`
+ # We need to temporarily replace default config path since
+ # npm otherwise tries to write outside of the sandbox
+ local npm_config="usr/$(get_libdir)/node_modules/npm/lib/config/core.js"
+ sed -i -e "s|'/etc'|'${ED}/etc'|g" "${ED}/${npm_config}" || die
+ local tmp_npm_completion_file="$(emktemp)"
+ "${ED}/usr/bin/npm" completion > "${tmp_npm_completion_file}"
+ newbashcomp "${tmp_npm_completion_file}" npm
+ sed -i -e "s|'${ED}/etc'|'/etc'|g" "${ED}/${npm_config}" || die
+
+ # Move man pages
+ doman "${LIBDIR}"/node_modules/npm/man/man{1,5,7}/*
+
+ # Clean up
+ rm "${LIBDIR}"/node_modules/npm/{.mailmap,.npmignore,Makefile} || die
+ rm -rf "${LIBDIR}"/node_modules/npm/{doc,html,man} || die
+
+ local find_exp="-or -name"
+ local find_name=()
+ for match in "AUTHORS*" "CHANGELOG*" "CONTRIBUT*" "README*" \
+ ".travis.yml" ".eslint*" ".wercker.yml" ".npmignore" \
+ "*.md" "*.markdown" "*.bat" "*.cmd"; do
+ find_name+=( ${find_exp} "${match}" )
+ done
+
+ # Remove various development and/or inappropriate files and
+ # useless docs of dependend packages.
+ find "${LIBDIR}"/node_modules \
+ \( -type d -name examples \) -or \( -type f \( \
+ -iname "LICEN?E*" \
+ "${find_name[@]}" \
+ \) \) -exec rm -rf "{}" \;
+ fi
+}
+
+src_test() {
+ out/${BUILDTYPE}/cctest || die
+ "${PYTHON}" tools/test.py --mode=${BUILDTYPE,,} -J message parallel sequential || die
+}
+
+pkg_postinst() {
+ einfo "The global npm config lives in /etc/npm. This deviates slightly"
+ einfo "from upstream which otherwise would have it live in /usr/etc/."
+ einfo ""
+ einfo "Protip: When using node-gyp to install native modules, you can"
+ einfo "avoid having to download extras by doing the following:"
+ einfo "$ node-gyp --nodedir /usr/include/node <command>"
+}