summaryrefslogtreecommitdiff
path: root/net-libs/xrootd/xrootd-4.10.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/xrootd/xrootd-4.10.1.ebuild')
-rw-r--r--net-libs/xrootd/xrootd-4.10.1.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/net-libs/xrootd/xrootd-4.10.1.ebuild b/net-libs/xrootd/xrootd-4.10.1.ebuild
index 84ac2910a28b..bdfdc4d72002 100644
--- a/net-libs/xrootd/xrootd-4.10.1.ebuild
+++ b/net-libs/xrootd/xrootd-4.10.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
inherit cmake-utils python-single-r1 user
@@ -14,7 +14,7 @@ SRC_URI="http://xrootd.org/download/v${PV}/${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples fuse http kerberos python readline rbd ssl test"
+IUSE="doc examples fuse http kerberos python readline ssl test"
RESTRICT="!test? ( test )"
CDEPEND="
@@ -22,7 +22,6 @@ CDEPEND="
fuse? ( sys-fs/fuse:= )
kerberos? ( virtual/krb5 )
python? ( ${PYTHON_DEPS} )
- rbd? ( sys-cluster/ceph )
readline? ( sys-libs/readline:0= )
ssl? ( dev-libs/openssl:0= )
"
@@ -56,7 +55,6 @@ pkg_setup() {
src_configure() {
local mycmakeargs=(
- -DENABLE_CEPH=$(usex rbd)
-DENABLE_CRYPTO=$(usex ssl)
-DENABLE_FUSE=$(usex fuse)
-DENABLE_HTTP=$(usex http)