summaryrefslogtreecommitdiff
path: root/net-libs/qxmpp/qxmpp-1.4.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/qxmpp/qxmpp-1.4.0.ebuild')
-rw-r--r--net-libs/qxmpp/qxmpp-1.4.0.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/net-libs/qxmpp/qxmpp-1.4.0.ebuild b/net-libs/qxmpp/qxmpp-1.4.0.ebuild
deleted file mode 100644
index c92352230daa..000000000000
--- a/net-libs/qxmpp/qxmpp-1.4.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="A cross-platform C++ XMPP client library based on the Qt framework"
-HOMEPAGE="https://github.com/qxmpp-project/qxmpp/"
-SRC_URI="https://github.com/${PN}-project/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug doc gstreamer test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-qt/qtcore:5
- dev-qt/qtnetwork:5[ssl]
- dev-qt/qtxml:5
- gstreamer? ( media-libs/gstreamer )
-"
-DEPEND="${RDEPEND}
- test? ( dev-qt/qttest:5 )
-"
-BDEPEND="
- doc? ( app-doc/doxygen )
-"
-
-src_prepare() {
- # requires network connection, bug #623708
- sed \
- -e "/qxmppiceconnection/d" \
- -e "/qxmppserver/d" \
- -e "/qxmpptransfermanager/d" \
- -i tests/CMakeLists.txt \
- || die "failed to drop certain network tests"
-
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_DOCUMENTATION=$(usex doc)
- -DBUILD_EXAMPLES=OFF
- -DBUILD_TESTS=$(usex test)
- -DBUILD_INTERNAL_TESTS=$(usex test)
- -DWITH_GSTREAMER=$(usex gstreamer)
- )
-
- cmake_src_configure
-}