summaryrefslogtreecommitdiff
path: root/net-libs/nghttp3
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/nghttp3')
-rw-r--r--net-libs/nghttp3/Manifest4
-rw-r--r--net-libs/nghttp3/metadata.xml11
-rw-r--r--net-libs/nghttp3/nghttp3-0_pre20190912.ebuild40
-rw-r--r--net-libs/nghttp3/nghttp3-9999.ebuild38
4 files changed, 93 insertions, 0 deletions
diff --git a/net-libs/nghttp3/Manifest b/net-libs/nghttp3/Manifest
new file mode 100644
index 000000000000..dfeb48fb6850
--- /dev/null
+++ b/net-libs/nghttp3/Manifest
@@ -0,0 +1,4 @@
+DIST nghttp3-0_pre20190912.tar.gz 155172 BLAKE2B fabd472e429222502288b7a4030b4aa51f8a1b609590d63b51ab3f918b8cdb462b766a40911986b3f72f2f1b0debee1f0ebdf8802991bf4fc5d4a6d14297bdcc SHA512 89c7b40843bde9d2c2ab24211794b6ae0e1fa15413e92dcf2238b876552f29bb2f0db724d9a205c2a1c98f25a14ef570c9e53df52fb519230b6f78dcc04d2117
+EBUILD nghttp3-0_pre20190912.ebuild 914 BLAKE2B d14d156e3f0f48b303ffd77af7b50b03e6535e29d88a6b58734868b7a0160c238b43c9f5dbb05030ea45a8a68c666f2c1b5547da9676ae244b46033c186d23ae SHA512 765cf54f2caf1f1800da5e5e1444ba9b2d9c0dc3f3129b88d1e34d1b5cb9f31d79863301aacabdc5b39d90c7e26f8a7f4d7c955806b1cf386598abe988a2dbd2
+EBUILD nghttp3-9999.ebuild 816 BLAKE2B 6ed5b177b9e1b88ee79445835e63d4ed9e93bd5ee9876159eec328b2f7e74b3ba957b55b8f63121ddba121010d4bbea97c8d7b83ebd15e9978360a2aafb10e03 SHA512 bbafe80a1d650151bdce8080e851c5c4ce252f241fd575716d1bc3f5a15fd56f71da1bf93c4c73c169115102a6d08ee25d6a6edd46f4e623fe531bc568509f20
+MISC metadata.xml 326 BLAKE2B 04521fe96f519c53e0a95a6a720be2e9828cb12ca5b51c6895d23e01e99d88d6b9970a5b01cdc9fc158444c01fd77e192a9071445f389df300e0fe9ec5c0d7f4 SHA512 02b24b1a01a3682c089affbba8f49eb19e1751362aa51306b9fd73e1050d465cf98511be57374321eb9b4fbb99db6c867995b9dcc1cc511b96d7286c039270bf
diff --git a/net-libs/nghttp3/metadata.xml b/net-libs/nghttp3/metadata.xml
new file mode 100644
index 000000000000..c31617286fee
--- /dev/null
+++ b/net-libs/nghttp3/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>candrews@gentoo.org</email>
+ <name>Craig Andrews</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ngtcp2/ngtcp2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-libs/nghttp3/nghttp3-0_pre20190912.ebuild b/net-libs/nghttp3/nghttp3-0_pre20190912.ebuild
new file mode 100644
index 000000000000..6489dde91d83
--- /dev/null
+++ b/net-libs/nghttp3/nghttp3-0_pre20190912.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ngtcp2/nghttp3.git"
+ inherit autotools git-r3
+else
+ GIT_COMMIT="51379a041174ad953dc6ad437712f3b279f81919"
+ SRC_URI="https://github.com/ngtcp2/nghttp3/archive/${GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${GIT_COMMIT}"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="HTTP/3 library written in C"
+HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
+
+LICENSE="MIT"
+SLOT="0/0"
+IUSE="test"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+RDEPEND=""
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_LIB_ONLY=ON
+ -DENABLE_EXAMPLES=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
+ )
+ cmake-utils_src_configure
+}
+
+multilib_src_test() {
+ cmake-utils_src_make check
+}
diff --git a/net-libs/nghttp3/nghttp3-9999.ebuild b/net-libs/nghttp3/nghttp3-9999.ebuild
new file mode 100644
index 000000000000..62a48b643ade
--- /dev/null
+++ b/net-libs/nghttp3/nghttp3-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ngtcp2/nghttp3.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://github.com/ngtcp2/nghttp3/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="HTTP/3 library written in C"
+HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
+
+LICENSE="MIT"
+SLOT="0/0"
+IUSE="test"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+RDEPEND=""
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_LIB_ONLY=ON
+ -DENABLE_EXAMPLES=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
+ )
+ cmake-utils_src_configure
+}
+
+multilib_src_test() {
+ cmake-utils_src_make check
+}