summaryrefslogtreecommitdiff
path: root/net-libs/nghttp2/nghttp2-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/nghttp2/nghttp2-9999.ebuild')
-rw-r--r--net-libs/nghttp2/nghttp2-9999.ebuild58
1 files changed, 21 insertions, 37 deletions
diff --git a/net-libs/nghttp2/nghttp2-9999.ebuild b/net-libs/nghttp2/nghttp2-9999.ebuild
index b24cbd6c83f0..fee50b41adf2 100644
--- a/net-libs/nghttp2/nghttp2-9999.ebuild
+++ b/net-libs/nghttp2/nghttp2-9999.ebuild
@@ -1,20 +1,18 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# TODO: Add python support.
-
EAPI=8
-inherit autotools git-r3 multilib-minimal
+inherit cmake-multilib git-r3
DESCRIPTION="HTTP/2 C Library"
HOMEPAGE="https://nghttp2.org/"
EGIT_REPO_URI="https://github.com/nghttp2/nghttp2.git"
LICENSE="MIT"
-SLOT="0/1.14" # <C++>.<C> SONAMEs
+SLOT="0/1.14" # 1.<SONAME>
KEYWORDS=""
-IUSE="cxx debug hpack-tools jemalloc static-libs systemd test utils xml"
+IUSE="debug hpack-tools jemalloc static-libs systemd test utils xml"
RESTRICT="!test? ( test )"
@@ -22,10 +20,6 @@ SSL_DEPEND="
>=dev-libs/openssl-1.0.2:0=[-bindist(-),${MULTILIB_USEDEP}]
"
RDEPEND="
- cxx? (
- ${SSL_DEPEND}
- dev-libs/boost:=[${MULTILIB_USEDEP}]
- )
hpack-tools? ( >=dev-libs/jansson-2.5:= )
jemalloc? ( dev-libs/jemalloc:=[${MULTILIB_USEDEP}] )
utils? (
@@ -34,41 +28,31 @@ RDEPEND="
>=sys-libs/zlib-1.2.3[${MULTILIB_USEDEP}]
net-dns/c-ares:=[${MULTILIB_USEDEP}]
)
- systemd? ( sys-apps/systemd )
+ systemd? ( >=sys-apps/systemd-209 )
xml? ( >=dev-libs/libxml2-2.7.7:2[${MULTILIB_USEDEP}] )"
DEPEND="${RDEPEND}
test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
BDEPEND="virtual/pkgconfig"
-src_prepare() {
- default
- eautoreconf
-}
-
multilib_src_configure() {
- local myeconfargs=(
- --disable-examples
- --disable-failmalloc
- --disable-python-bindings
- --disable-werror
- --enable-threads
- --without-cython
- $(use_enable cxx asio-lib)
- $(use_enable debug)
- $(multilib_native_use_enable hpack-tools)
- $(multilib_native_use_with hpack-tools jansson)
- $(multilib_native_use_with jemalloc)
- $(use_enable static-libs static)
- $(multilib_native_use_with systemd)
- $(use_with test cunit)
- $(multilib_native_use_enable utils app)
- $(multilib_native_use_with xml libxml2)
+ local mycmakeargs=(
+ -DENABLE_EXAMPLES=OFF
+ -DENABLE_FAILMALLOC=OFF
+ -DENABLE_WERROR=OFF
+ -DENABLE_THREADS=ON
+ -DENABLE_DEBUG=$(usex debug)
+ -DENABLE_HPACK_TOOLS=$(multilib_native_usex hpack-tools)
+ $(cmake_use_find_package hpack-tools Jansson)
+ -DWITH_JEMALLOC=$(multilib_native_usex jemalloc)
+ -DENABLE_STATIC_LIB=$(usex static-libs)
+ $(cmake_use_find_package systemd Systemd)
+ $(cmake_use_find_package test CUnit)
+ -DENABLE_APP=$(multilib_native_usex utils)
+ -DWITH_LIBXML2=$(multilib_native_usex xml)
)
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+ cmake_src_configure
}
-multilib_src_install_all() {
- if ! use static-libs ; then
- find "${ED}"/usr -type f -name '*.la' -delete || die
- fi
+multilib_src_test() {
+ eninja check
}