summaryrefslogtreecommitdiff
path: root/net-libs/neon
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/neon')
-rw-r--r--net-libs/neon/Manifest2
-rw-r--r--net-libs/neon/neon-0.31.2.ebuild105
2 files changed, 0 insertions, 107 deletions
diff --git a/net-libs/neon/Manifest b/net-libs/neon/Manifest
index 288ce1c4508b..a568cfdb9ba2 100644
--- a/net-libs/neon/Manifest
+++ b/net-libs/neon/Manifest
@@ -1,5 +1,3 @@
-DIST neon-0.31.2.tar.gz 867914 BLAKE2B 8ae1301dd5f9ac1a6b518f99919a1b7e7b7c6499413b523ff82e00d364d6d9c5ad96875795330e2fd9c42a42b073e3eea51b6cc0ee9e9a21850763f0cdd0b97e SHA512 1e402b40a0445f68ed24d2697ee60d21636f61ebc98edcde37ff9e26c54430acabf3969ac22a942d1dd51bddee0f312c04073b423b0af3a3e7c9bf60cd53e48c
DIST neon-0.32.2.tar.gz 880651 BLAKE2B 3629eee38e10ada5e001bf0afb77c70814083bf553596fc150a6cf21f0b66cf4de28841b242f68faaeb44fa5e0ad260939102b015d2a543ef59012876256b364 SHA512 2580a3c8c3cf4aff2d399f72a721ccfb4e68434ef92da4af8103c126812d779b9fbe5cafbab512c79f4365bbb3d3eac61568748136470e86f7aa7b98b27053c8
-EBUILD neon-0.31.2.ebuild 2652 BLAKE2B e718aeeb582f1d0ea1fb0460dfdee36bb29241a22848ff5cbe4831a6ed9b8b909098583e228c3c2d9ba33199999b3d2a322ae58915d48a542bf4e0235031c31f SHA512 5107c9be940005e1bff5b20bdf878b96c0ee94817812139f5f7c3875020c64731eda7a22221b0519b769936143d868757849314ba48403e1140ab0402e69582f
EBUILD neon-0.32.2.ebuild 2545 BLAKE2B 2bdaf5adc9eb2a2bbca5dac9343cacafc02a8bad0e4a46537abef40fd0b0f94f78973c6150dfe4c621c12de21d3eedcfb0a080e6351e88632cda9625806cca1a SHA512 3343166f5535c5c4d9b56e3b9958e5d49508f6435519e4a20a6364cb411464aee88cdb45c69bf18bc1de222902bf4adec04c45233c5cf6cdb2855f2f46746e3e
MISC metadata.xml 1465 BLAKE2B cc9629974affeda497ea2825a4412182f9445f90ef04eb1337a456fad1b578a30d6b1135255b278cf795ffa9be7d78e810797fc7fd170606e52e48f7af5e02fc SHA512 ca250ba34c8c50c20d92a60b138e6548920f9fead9c5dda3a18928bd06203f6952c4a6a2a0eee846c3f7bcd48c79959c92af9a0fd1a5133273fdc09fcbb051f3
diff --git a/net-libs/neon/neon-0.31.2.ebuild b/net-libs/neon/neon-0.31.2.ebuild
deleted file mode 100644
index 77dd704a1b7b..000000000000
--- a/net-libs/neon/neon-0.31.2.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 2001-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools libtool multilib-minimal
-
-DESCRIPTION="HTTP and WebDAV client library"
-HOMEPAGE="https://notroj.github.io/neon/"
-SRC_URI="https://notroj.github.io/neon/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0/27"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc expat gnutls kerberos libproxy nls pkcs11 ssl static-libs zlib"
-RESTRICT="test"
-
-RDEPEND="expat? ( dev-libs/expat:0=[${MULTILIB_USEDEP}] )
- !expat? ( dev-libs/libxml2:2=[${MULTILIB_USEDEP}] )
- kerberos? ( virtual/krb5:0=[${MULTILIB_USEDEP}] )
- libproxy? ( net-libs/libproxy:0=[${MULTILIB_USEDEP}] )
- nls? ( virtual/libintl:0=[${MULTILIB_USEDEP}] )
- ssl? (
- gnutls? (
- app-misc/ca-certificates
- net-libs/gnutls:0=[${MULTILIB_USEDEP}]
- )
- !gnutls? (
- dev-libs/openssl:0=[${MULTILIB_USEDEP}]
- )
- pkcs11? ( dev-libs/pakchois:0=[${MULTILIB_USEDEP}] )
- )
- zlib? ( sys-libs/zlib:0=[${MULTILIB_USEDEP}] )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-MULTILIB_CHOST_TOOLS=(
- /usr/bin/neon-config
-)
-
-src_prepare() {
- # Use CHOST-prefixed version of xml2-config for cross-compilation.
- sed -e "s/AC_CHECK_PROG(XML2_CONFIG,/AC_CHECK_TOOL(XML2_CONFIG,/" -i macros/neon-xml-parser.m4 || die "sed failed"
-
- # Fix compatibility with OpenSSL >=1.1.
- sed -e "s/RSA_F_RSA_PRIVATE_ENCRYPT/RSA_F_RSA_OSSL_PRIVATE_ENCRYPT/" -i src/ne_pkcs11.c || die "sed failed"
-
- eapply_user
-
- AT_M4DIR="macros" eautoreconf
-
- elibtoolize
-
- multilib_copy_sources
-}
-
-multilib_src_configure() {
- local myconf=()
-
- if has_version sys-libs/glibc; then
- einfo "Enabling SSL library thread-safety using POSIX threads..."
- myconf+=(--enable-threadsafe-ssl=posix)
- fi
-
- if use expat; then
- myconf+=(--with-expat)
- else
- myconf+=(--with-libxml2)
- fi
-
- if use ssl; then
- if use gnutls; then
- myconf+=(--with-ssl=gnutls --with-ca-bundle="${EPREFIX}/etc/ssl/certs/ca-certificates.crt")
- else
- myconf+=(--with-ssl=openssl)
- fi
- fi
-
- econf \
- --enable-shared \
- $(use_with kerberos gssapi) \
- $(use_with libproxy) \
- $(use_enable nls) \
- $(use_with pkcs11 pakchois) \
- $(use_enable static-libs static) \
- $(use_with zlib) \
- "${myconf[@]}"
-}
-
-multilib_src_install() {
- emake DESTDIR="${D}" install-{config,headers,lib,man,nls}
-
- if multilib_is_native_abi && use doc; then
- (
- docinto html
- dodoc -r doc/html/*
- )
- fi
-}
-
-multilib_src_install_all() {
- find "${D}" -name "*.la" -type f -delete || die
-
- dodoc AUTHORS BUGS NEWS README.md THANKS TODO
-}