summaryrefslogtreecommitdiff
path: root/net-libs/nDPI/nDPI-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/nDPI/nDPI-9999.ebuild')
-rw-r--r--net-libs/nDPI/nDPI-9999.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/net-libs/nDPI/nDPI-9999.ebuild b/net-libs/nDPI/nDPI-9999.ebuild
index a7730e61c252..e2efa26265f9 100644
--- a/net-libs/nDPI/nDPI-9999.ebuild
+++ b/net-libs/nDPI/nDPI-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools
+inherit autotools edo
DESCRIPTION="Open Source Deep Packet Inspection Software Toolkit"
HOMEPAGE="https://www.ntop.org/"
@@ -34,11 +34,17 @@ src_prepare() {
eautoreconf
}
+src_configure() {
+ # "local" here means "local to the system", and hence means
+ # system copy, not the bundled one.
+ econf --with-local-libgcrypt
+}
+
src_test() {
pushd tests || die
- ./do.sh || die "Failed tests"
- ./do-unit.sh || die "Failed unit tests"
+ edo ./do.sh
+ edo ./do-unit.sh
popd || die
}