summaryrefslogtreecommitdiff
path: root/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.2.15-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.2.15-r1.ebuild')
-rw-r--r--net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.2.15-r1.ebuild69
1 files changed, 0 insertions, 69 deletions
diff --git a/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.2.15-r1.ebuild b/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.2.15-r1.ebuild
deleted file mode 100644
index 94e0b8f3d964..000000000000
--- a/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.2.15-r1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8,9,10} )
-
-inherit cmake python-single-r1
-
-DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
-HOMEPAGE="https://libtorrent.org/ https://github.com/arvidn/libtorrent"
-SRC_URI="https://github.com/arvidn/libtorrent/releases/download/v${PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/10"
-KEYWORDS="amd64 ~arm ~ppc ~ppc64 ~sparc x86"
-IUSE="+dht debug python ssl test"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-libs/boost:=[threads(+)]
- python? (
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-libs/boost[python,${PYTHON_USEDEP}]
- ')
- )
- ssl? ( dev-libs/openssl:= )
-"
-RDEPEND="${DEPEND}"
-BDEPEND="python? (
- $(python_gen_cond_dep '
- dev-python/setuptools[${PYTHON_USEDEP}]
- ')
- )"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_SHARED_LIBS=ON
- -Dbuild_examples=OFF
- -Ddht=$(usex dht ON OFF)
- -Dencryption=$(usex ssl ON OFF)
- -Dlogging=$(usex debug ON OFF)
- -Dpython-bindings=$(usex python ON OFF)
- -Dbuild_tests=$(usex test ON OFF)
- )
-
- # We need to drop the . from the Python version to satisfy Boost's
- # FindBoost.cmake module, bug #793038.
- use python && mycmakeargs+=( -Dboost-python-module-name="${EPYTHON/./}" )
-
- cmake_src_configure
-}
-
-src_test() {
- local myctestargs=(
- # Needs running UPnP server
- -E "test_upnp"
- )
-
- # Checked out Fedora's test workarounds for inspiration
- # https://src.fedoraproject.org/rpms/rb_libtorrent/blob/rawhide/f/rb_libtorrent.spec#_120
- LD_LIBRARY_PATH="${BUILD_DIR}:${LD_LIBRARY_PATH}" cmake_src_test
-}